Forum > Lazarus Extra Components

RXnew: RXnew does not compile in Lazarus 2.0.10

(1/5) > >>

RXnew does not compile in Lazarus 2.0.10

--- Code: Pascal  [+][-]window.onload = function(){var x1 = document.getElementById("main_content_section"); if (x1) { var x = document.getElementsByClassName("geshi");for (var i = 0; i < x.length; i++) { x[i].style.maxHeight='none'; x[i].style.height = Math.min(x[i].clientHeight+15,306)+'px'; x[i].style.resize = "vertical";}};} ---rxnew.pas(11,3) Fatal: Nie można znaleźć LazarusPackageIntf used by rxnew. Make sure all ppu files of a package are in its output directory. ppu in wrong directory=d:\lazarus210\packager\units\i386-win32\lazaruspackageintf.ppu. Clean up package "FCL"..

Add FCL to RXnew package requirements:
package window > Add > New requirement > FCL

Just tried it myself: Installed the new Laz2.0.10/FPC3.2.0 (Win10 / 32 bit) as secondary installation and tried to install rxnew via OPM (checked only the rxnew and rxtools packages in the RX node of OPM - rxtools is required by rxnew). Installation of rxnew aborts with error "cannot be installed", rxtools succeeds. Did manual install of rxnew later - no problems now.

I don't know what's wrong here. Does OPM really fail to detect that rxtools is required by rxnew? (*)

But anyway: I did not experience the FCL error that you mention. Can you try a clean recompilation of the IDE? (Tools > Configure Build Lazarus > in the "clean-up" box check "Clean all" and "Switch after building to automatically" > Build.)


[EDIT] Deleted the Laz Config folder and did a clean rebuild of the IDE to reset to the state after installation. Then I repeated the rxnew installtion. But this time I only checked "rxnew" in OPM. Now I was asked whether the packages "rxtools" should be installed too. After confirmation the installation was executed without any issues.

I tried install from lazarus ccr svn

No problem with that either. Did you try a clean build?


[0] Message Index

[#] Next page

Go to full version