Recent

Author Topic: LAMW 0.8.5 on FPC 3.2.0 and Lazarus 2.0.8  (Read 335 times)

process_1

  • New Member
  • *
  • Posts: 13
LAMW 0.8.5 on FPC 3.2.0 and Lazarus 2.0.8
« on: June 28, 2020, 08:29:34 am »
I have followed steps to install latest LAMW form OPM on latest Ubuntu 64bit.

After successful installation and trying to create new Android project, this error was shown:
Code: [Select]
Fail! Folder /platforms is empty!
Adding the Workspace for android using default settings creating new project (ARMv7a+Soft), this AV popup:

Code: [Select]
Invalid floating point operation.

Press OK to ignore and risk data corruption.
Press Abort to kill the program.

I'm not certain what I have missed.

process_1

  • New Member
  • *
  • Posts: 13
Re: LAMW 0.8.5 on FPC 3.2.0 and Lazarus 2.0.8
« Reply #1 on: June 28, 2020, 10:35:57 am »
BTW, I have followed this guide precisely:

https://forum.lazarus.freepascal.org/index.php/topic,45361.0.html

Android SDK Build-Tools 28.0.3
SDK Platform API 28 Rev 6

Etc. What I would need to install precisely from Android SDK Manager?

DanielTimelord

  • New Member
  • *
  • Posts: 28
Re: LAMW 0.8.5 on FPC 3.2.0 and Lazarus 2.0.8
« Reply #2 on: June 30, 2020, 05:32:30 pm »
Hello,
ARMv7+soft isn't supported, use armv7+fvp3!
by default arm+vfpv3 is marked!
To fix "platorm folder is empty!" try command: ./lamw_manager --reset-aapis

If don't work  use  command: ./lamw_manager --reset to full reset!
« Last Edit: June 30, 2020, 05:57:13 pm by DanielTimelord »

 

TinyPortal © 2005-2018