Recent

Author Topic: TDBMemo, ZEOSLib, MySQL Post Problem  (Read 3415 times)

piper62

  • New Member
  • *
  • Posts: 41
TDBMemo, ZEOSLib, MySQL Post Problem
« on: February 10, 2008, 04:39:25 am »
Hi,

I have a strange behaviour of my code.
My environment is: Kubuntu 7.10, FPC 2.2/Lazarus 0.9.24 and ZEOSLIB 6.6.1 Trunk_310, MySQL 5.0 .
A ZQuery has a connection to a table where DBEdit1 is connected to a VARCHAR(250) field and DBMemo1 is connected to a TEXT field.
In the code I do this:
  ZQuery1.Append;
  DBEdit1.Text:=v_fo_name; //variable holds some text.
  DBMemo1.Lines.LoadFromFile(filename); //filename points to a ascii file.

The file gets loaded into the DBMemo and it's displayed correctly also the text from the variable v_fo_name is correct in the DBEdit.
If I now perform ZQuery1.Post; the data of the DBEdit is written correctly into the database table but not the content of the DBMemo.

Only if I click to the DBMemo AND change something in the text the data is stored into the database by ZQuery.Post.
Only to click into the DBMemo or SetFocus in not enough. I have to change the text.
Is this a bug? Or do I something wrong?

Regards,
Tibor

piper62

  • New Member
  • *
  • Posts: 41
TDBMemo, ZEOSLib, MySQL Post Problem
« Reply #1 on: February 14, 2008, 08:05:13 pm »
Hi,

an update to the problem:
If I use GTK2 instead of GTK1.2 the problem doesn't occur.
So it's a GTK1.2 problem.

Has anybody an idea? I filed already a bug report.

Regards,
Tibor

 

TinyPortal © 2005-2018