Forum > FV/Textmode IDE

DOS IDE Debugger

(1/2) > >>

I cannot use the FPC IDE integrated debugger for DOS since FPC 2.X  (stepping, tracing, etc. as it craches, hangs). So I'm still using FPC 1.0.X for this purpose. With the new FPC release 3.2.X I can see there are some signs of life of the internal debugger but it still fails if the source file size is larger than a couple of KB (even if there is just one intruction and other context are comments).

I wonder if DOS IDE debugging is in real development or it is just some dummy/obsolete functionality. Is it in use by someone? Should I report bugs, etc. (I cannot find any bugtracker reports regarding DOS IDE debugger).

I found GDB libgdb libraries v7.7.1 for compiling DOS IDE with debugger support here:

Suprisingly they are recently updated (29.03.2020) however GDB version is not actual (AFAIK there is already GDB v9.1 released on Feb, 8th, 2020, but I don't know how to compile new libgdb files for FPC IDE).

I can see Debugging on other platforms became really stable (especially with the use of MI interface still not supported in DOS). Is there any information on plans regarding the FPC IDE debugger for DOS? Maybe some help is needed? Or nobody is really interesed.

Just for clarification: are you simply talking about the TextMode IDE or are you talking about using the IDE on DOS?

I mean using on real DOS (not console/terminal box). Maybe I'm writing in the wrong section.

No, the section is alright. It's just that many people call the TextMode IDE “DOS IDE” without wanting to use it on DOS.

I think one of the problems is that it's rather hard to get the GDB build system to build the static library nowadays (that's why we introduced the GDBMI interface with 3.2 for targets that can make use of it).

You could try whether you can reproduce your crashes with a standalone GDB to pinpoint whether it's a problem of GDB in general or of the static library or the way the TextMode IDE uses the debugger...

Is MI Interface can be supported in DOS? It is possible to compile IDE for DOS with GDBMI option but this IDE even cannot start debugging and halts.

Regarding the source of the problem I found FPC IDE compiled in debug mode a bit more stable but this doesn't yet allow concluding the problem is with FPC.

I just tried a standalone DOS debugger v.6.11 I was able to find within FPC packages (thank you for suggestion) but I'm not sure if it is working at all. When I try stepping it hangs always. At the same time there is at least some success with integrated libraries for the GDB v.7.7.1 but I cannot find their standalone version.

Could you please suggest where I can find a newer DOS version of the debugger for DOS? The libraries v.7.7.1 were generated somehow:


[0] Message Index

[#] Next page

Go to full version