Recent

Author Topic: [SOLVED] lamw Android - jButton Event onup and ondown needed  (Read 461 times)

six1

  • Jr. Member
  • **
  • Posts: 86
[SOLVED] lamw Android - jButton Event onup and ondown needed
« on: April 08, 2020, 02:54:48 pm »
Hi,
i need jButton events similar to TButton onmousedown and onmouseup.
have had a look at other components, but doesn't found Component with onup and ondown.

any idea?

best, michael
« Last Edit: April 09, 2020, 09:51:54 am by six1 »

six1

  • Jr. Member
  • **
  • Posts: 86
Re: lamw Android - jButton Event onup and ondown needed
« Reply #1 on: April 09, 2020, 09:51:32 am »
Solved it with jImageView Component.

Sirius Black

  • New Member
  • *
  • Posts: 19
Re: lamw Android - jButton Event onup and ondown needed
« Reply #2 on: April 09, 2020, 10:39:11 am »
Solved it with jImageView Component.

Be careful, I have this problem when using jImageView that act as button

six1

  • Jr. Member
  • **
  • Posts: 86
Re: [SOLVED] lamw Android - jButton Event onup and ondown needed
« Reply #3 on: April 09, 2020, 10:59:57 am »
ok, readed your problem, but can't see it in my APP. I'm developing on SDK 28, maybe that's the difference?

jImageView is acting as expected...

Sirius Black

  • New Member
  • *
  • Posts: 19
Re: [SOLVED] lamw Android - jButton Event onup and ondown needed
« Reply #4 on: April 09, 2020, 12:09:23 pm »
ok, readed your problem, but can't see it in my APP. I'm developing on SDK 28, maybe that's the difference?

jImageView is acting as expected...

What version of your android? Have you tried android 10?

six1

  • Jr. Member
  • **
  • Posts: 86
Re: [SOLVED] lamw Android - jButton Event onup and ondown needed
« Reply #5 on: April 09, 2020, 12:44:18 pm »
jdk1.8.0_162
android-ndk-r10e
apache-ant-1.9.6
gradle-6.3

SDK Manager installed SDK 23, 25, 27, 28, 29


i tried Anroid 9.1.0 and 6.0
« Last Edit: April 09, 2020, 12:46:07 pm by six1 »

Sirius Black

  • New Member
  • *
  • Posts: 19
Re: [SOLVED] lamw Android - jButton Event onup and ondown needed
« Reply #6 on: April 10, 2020, 11:29:38 pm »
jdk1.8.0_162
android-ndk-r10e
apache-ant-1.9.6
gradle-6.3

SDK Manager installed SDK 23, 25, 27, 28, 29


i tried Anroid 9.1.0 and 6.0

Oh ok. It's good for you

 

TinyPortal © 2005-2018