Forum > General

Amiga Classic



 two days free (week-end) and nostalgic mood. Is there someone that could tell me how to get compiler for classic Amiga OS?
 I have A500+ (bought few years ago) with WB3.0 Can I run command-line application (not to mention about gui app)?


There is an Amiga Wiki:

I wish you not so much Guru Meditations!


Hello Krolikbest

Please do keep in mind that it is better to cross-compile. The Amiga filesystem is terribly slow and FPC is very memory hungry (compared to the specs of the hardware). It is possible though, although  i do prefer emulation in case i want to compile "native".

Don't forget about vasm/vlink as those are default for native. the gnu binutils are a) difficult to setup and b) hopelessly out of date.Though there are some initiatives to improve that situation (I haven;'t tried them myself).

Also, the default compiler does only support 68020 cpu's and workbench /kickstart 3.x. Charlie recently made some progress on adding legacy support for (old) workbench/kickstart combinations which would imply also having added support for 68000 cpu as well.You can find a page here:

I haven't tried legacy myself yet, so can't tell if it will/should work for you or not.

Don't forget to have fun ! :-)

 Hi again,

Sorry i forgot to answer this part:

--- Quote ---Can I run command-line application (not to mention about gui app)?

--- End quote ---
Yes of course you can run commandline applications. What else would be the use to target this platform ? :-)

GUI applications, yes. But with a caveat: it requires MUI 3. You can even run Lazarus if you have a very beefed up Amiga. If that is useful... well not exactly. For that you better cross-compile.

Besides that, MUI isn't really suited for Lazarus widgets, but it does work. We've tried fpGUI as well, which does run as well. It is no problem creating native MUI or intuition applications. ALB has even a special MUI class for that (which is also used for Lazarus).

Take a look at ALB's blog: where he showcases his apps (He ocassionally drops my name there as well ;-) )


having last two days free I came back to crosscompilation for Amiga( in my case it is WinUAE installation). With new ver of fpcupdeluxe on Win7 64bit finally I'm able to compile for this OS (workbench 3.1, cpu 68020). However (maybe a step to far..) I became interested in running mui application as well so I installed something called mui36usr on Amiga side in order to launch application written in Lazarus - without this I got Guru meditaions :). So far I can compile and launch MUI applications and while I can move/resize form it seems that other components don't respond to any  other action e.g like button mouse click, enter into edit component.  I suspect incompatibility of mui38usr with mui widgetset of Lazarus but maybe someone could me enlighten?


[0] Message Index

Go to full version