Recent

Author Topic: Problem with installing on a new Mac with Catalina  (Read 762 times)

Igor Kokarev

  • Full Member
  • ***
  • Posts: 216
Problem with installing on a new Mac with Catalina
« on: March 27, 2020, 01:53:08 pm »
Hi,

We have 2 problems with installing fpc and Lazarus on a new iMac with Catalina:

1.
fpc-3.0.4a.intel-macosx.dmg is being refused by Catalina (10.15.3) stating it is an incompatible package.

2.
Another step described in wiki cannot be performed:

Code: Pascal  [Select][+][-]
  1. open /Library/Developer/CommandLineTools/Packages/macOS_SDK_headers_for_macOS_10.14.pkg
Because there is no file macOS_SDK_headers_for_macOS_10.14.pkg

lucamar

  • Hero Member
  • *****
  • Posts: 3025
Re: Problem with installing on a new Mac with Catalina
« Reply #1 on: March 27, 2020, 02:34:26 pm »
There is already a topic about this problem:
https://forum.lazarus.freepascal.org/index.php/topic,47408.0.html
Turbo Pascal 3 CP/M - Amstrad PCW 8256 (512 KB !!!) :P
Lazarus 2.0.8/FPC 3.0.4 - 32/64 bits on:
(K|L|X)Ubuntu 12..18, Windows XP, 7, 10 and various DOSes.

Igor Kokarev

  • Full Member
  • ***
  • Posts: 216
Re: Problem with installing on a new Mac with Catalina
« Reply #2 on: March 27, 2020, 11:36:36 pm »
Yes, regrettable there was no reply or solution there. Also I found 2nd problem, not mentioned there.
« Last Edit: March 27, 2020, 11:38:29 pm by Igor Kokarev »

trev

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 943
  • Former Delphi 1-7, 10.2 User
Re: Problem with installing on a new Mac with Catalina
« Reply #3 on: March 28, 2020, 02:36:07 am »
Please follow these instructions which I have just updated on the Wiki for macOS 10.15 Catalina.

There are five steps. It took just over five minutes to follow them and successfully install FPC, FPC source and the Lazarus IDE on Catalina.

o Lazarus v2.1.0 r63871, FPC v3.3.1 r46876, macOS 10.14.6 (with sup update), Xcode 11.3.1
o Lazarus v2.1.0 r61574, FPC v3.3.1 r42318, FreeBSD 12.1 amd64 (VMware Fusion VM)
o FPC 3.0.4, FreeBSD 12.2-STABLE r365646 amd64
o Lazarus v2.1.0 r61574, FPC v3.0.4, Ubuntu 18.04 (Parallels VM)

Igor Kokarev

  • Full Member
  • ***
  • Posts: 216
Re: Problem with installing on a new Mac with Catalina
« Reply #4 on: March 28, 2020, 05:38:55 pm »
trev,

Thanks for your advices and update wiki article! I very appreciate your help.

It's very important to help programmers who want to work with Lazarus on latest macOS Catalina.

 

TinyPortal © 2005-2018