Recent

Author Topic: First Lazarus build help  (Read 1144 times)

daveinhull

  • Sr. Member
  • ****
  • Posts: 273
  • 1 divided by nothing must still be 1!
First Lazarus build help
« on: March 19, 2020, 02:04:42 pm »
Hi

I'm trying to build Lazarus for the first time and I'm getting stuck.
I've tried following the tips given by GetMem, installed TortoiseSVN and checked out the source.
However when I come to run Lazarus.bat it says Make is not recognized. I've installed GnuWin32\make.exe, but now it says makefile:29: *** You need the GNU utils package to use this Makefile.  Stop.
I also had to put the full directory reference for Make as I can't seem to get a path to it to work using environment variables.
any help in getting this last bit sorted would be great

Thanks
Dave


@Otto

1. Install TorotiseSVN(https://tortoisesvn.net/downloads.html), it's free
2. Create a "Lazarus" folder somewhere
3. Right click "Lazarus" folder, then "SVN Checkout...". The following dialog will apear(see screenshot1)
4. Type/paste in the URL: "https://svn.freepascal.org/svn/lazarus/trunk" , press OK
5. After the checkout is done, create a batch file(lazarus.bat for example), with the following content:
Quote
set path=C:\FPC\3.0.4\bin\i386-win32\;
make bigide
where the path must point to a valid FPC installation
6. Copy lazarus.bat inside the Lazarus folder, then doubleclick the bat file. If everything works well, the trunk IDE is build.
7. To create a patch, right click Lazarus folder then click "Create patch...". See attachment2.

PS: Make sure you backup your config folder, just in case. If you have a standard installation lazarus trunk may overwrite the settings.
Version #:1.8.4 Date 2019-01-08 FPC Version: 3.0.4 and SVN Revision 57972 for x86_64-win64-win32/win64

af0815

  • Hero Member
  • *****
  • Posts: 678
Re: First Lazarus build help
« Reply #1 on: March 19, 2020, 02:11:58 pm »
for the fist time, it is the best to use a preconfigured package. If not the next try is to look for fpcupdeluxe in the lazarus wiki and use this.

The quto from GetMem means you must have a functinal basic system with the tools and fpc ! This is NOT for the first try -> see: must point to a valid FPC installation !
regards
Andreas

daveinhull

  • Sr. Member
  • ****
  • Posts: 273
  • 1 divided by nothing must still be 1!
Re: First Lazarus build help
« Reply #2 on: March 19, 2020, 02:35:32 pm »
Hi af0815,

Thanks, sorry I should have mentioned that I do already have a preconfigured version installed and have been using it for a number of years, but there is a bug in one of the DB controls that I've reported which I need and I'm hoping that if I can install a latest daily build it might be fixed.

I'll take a look at fpcupdelux

Thanks again
Dave
Version #:1.8.4 Date 2019-01-08 FPC Version: 3.0.4 and SVN Revision 57972 for x86_64-win64-win32/win64

 

TinyPortal © 2005-2018