Recent

Author Topic: Cannot compile BGRAControls: Access violation error (panic, internal error)  (Read 355 times)

att2

  • New Member
  • *
  • Posts: 49
Hello,

My system: VM with Linux Mint 19/Tara with latest updates, LAZ 2.1.0, FPC 3.3.1beta by install method of latest FPCUPDeluxe 1.8.6d.

Trying to install BGRAControls via Online-Package-Manager gives compile error :

Kompiliere Package bgracontrols 6.6.1: Access violation
  $0000000000536ACD
  $0000000000536CCE
  $00000000009C6560  EXECUTE,  line 1603 of exttools.pas
, Fehler: 4, Warnungen: 6, Hinweise: 2
bctools.pas(281,3) Warning: Case statement does not handle all possible cases
bctools.pas(581,14) Hint: Local variable "p" of a managed type does not seem to be initialized
bctools.pas(670,3) Warning: Case statement does not handle all possible cases
bceffect.pas(184,3) Warning: Case statement does not handle all possible cases
bceffect.pas(224,3) Warning: Case statement does not handle all possible cases
bcfilters.pas(320,21) Hint: Local variable "gpallete" of a managed type does not seem to be initialized
bcfilters.pas(797,3) Warning: Case statement does not handle all possible cases
Warning: Recompiling BGRASliceScaling, checksum changed for /home/arm2/programme/lazarus/config_lazarus/onlinepackagemanager/packages/bgrabitmap-master/bgrabitmap/lib/x86_64-linux/3.3.1/bgrabitmap.ppu
Panic: interner Fehler: Access violation
Panic: interner Fehler:   $0000000000536ACD
Panic: interner Fehler:   $0000000000536CCE
Panic: interner Fehler:   $00000000009C6560  EXECUTE,  line 1603 of exttools.pas

-----------
Now what to do ? How to install it ?

 

TinyPortal © 2005-2018