Recent

Author Topic: Is lazopenglcontext supported in Cocoa?  (Read 588 times)

lelebass

  • New Member
  • *
  • Posts: 36
Is lazopenglcontext supported in Cocoa?
« on: March 17, 2020, 05:18:00 pm »
I am trying to test a simple OpenGL application using Lazarus 2.0.6 x86_64 but seems that there is something missing in the Cocoa implementation.

If I try to install the lazopenglcontext using fpcupdeluxe I get the following error:

/Applications/fpcupdeluxe/lazarus/components/opengl/glcocoanscontext.pas(506,45) Error: (5038) identifier idents no member "KeyEvent"

Ciao,
Daniele

ChrisR

  • Full Member
  • ***
  • Posts: 124
Re: Is lazopenglcontext supported in Cocoa?
« Reply #1 on: March 17, 2020, 08:37:59 pm »
There is a bug when compiling OpenGL for the Cocoa widgets with Lazarus 2.0.6. It may be
  https://bugs.freepascal.org/view.php?id=35797
regardless, I think if you replace the code in 2.0.6 with the code from Trunk it should work
  https://svn.freepascal.org/svn/lazarus/trunk/components/opengl/glcocoanscontext.pas

lelebass

  • New Member
  • *
  • Posts: 36
Re: Is lazopenglcontext supported in Cocoa?
« Reply #2 on: March 19, 2020, 11:42:13 am »
Thanks for the answer.

Looks like it is a different issue, I tried to copy the glcocoanscontext.pas from trunk but still got the same error:

glcocoanscontext.pas(506,45) Error: identifier idents no member "KeyEvent"

Should I file a bug report?

Ciao,
Daniele

skalogryz

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2457
    • havefunsoft.com
Re: Is lazopenglcontext supported in Cocoa?
« Reply #3 on: March 20, 2020, 03:36:24 am »
very interesting.
there's no "keyEvent" in the current trunk version of glcocoanscontext.pas

is it possible that you've some local modifications to your glcocoanscontext.pas?
so switching to trunk doesn't overwrite the file?
Patron Cocoa Widgetset development https://www.patreon.com/skalogryz

lelebass

  • New Member
  • *
  • Posts: 36
Re: Is lazopenglcontext supported in Cocoa?
« Reply #4 on: March 29, 2020, 09:30:40 am »
I was able to install latest Trunk svn 62815 using fpcupdeluxe 1.6.8i. Now the simple application with lazopenglcontext works. I suppose the problem with Lazarus 2.0.6 has been solved. Now I can start to port my application to Cocoa, I was stuck with the lazopenglcontext for a wihle. Which Lazarus version should I use: Trunk or Fixes? What do you recommend?

Thanks!

Daniele
« Last Edit: March 29, 2020, 05:43:12 pm by lelebass »

 

TinyPortal © 2005-2018