Author Topic: [SOLVED] trunk: can not properly handle fppkg.cfg when start  (Read 1652 times)


  • New Member
  • *
  • Posts: 33
[SOLVED] trunk: can not properly handle fppkg.cfg when start
« on: February 24, 2020, 10:08:06 pm »
every time start lazarus, got the initial wizard because fppkg configuration problem (Fppkg reports that the RTL is not installed.)
try to do "Restore Fppkg configuration", not success.

already found why this happened:
in my environments have multi fpc version installed,
I put them all in C:\fpc directory, and by {FPCVERSION}-{TARGETOS} directory,
currently have: 3.0.4-win32, 3.0.4-win64, 3.2.0-win64,
lazarus-trunk was build by 3.2.0-win64

in the "Generate new Fppkg configuration files" dialog,
it said need a prefix that contain "3.2.0\units" and/or "3.2.0\fpmkinst"

in my situation, I can not give any valid prefix that contained "{FPCVERSION}\{units,fpmkinst}"
the multi fpc version layout was used for years and I think it's good for multi version co-exists

so, is there any **smarter** solution to make fppkg work? is this prefix required by fpc or lazarus?

  I update my build scripts, now put win32/win64 to c:\fpc\3.2.0 directory together.
« Last Edit: March 03, 2020, 08:35:20 pm by baldzhang »


  • Hero Member
  • *****
  • Posts: 568
Re: [SOLVED] trunk: can not properly handle fppkg.cfg when start
« Reply #1 on: January 27, 2022, 07:09:29 am »
I faced such a problem today and I developed a solution as follows. Let's put it here, maybe it will help someone one day.
If Ide=Lazarus 2.0.10 32 Bit and Os=Win 10 Home 64 Bit then Get up and do something useful! Because God is the helper of those who start again;


TinyPortal © 2005-2018