Author Topic: ARM LoadLibrary problem  (Read 281 times)


  • New Member
  • *
  • Posts: 17
ARM LoadLibrary problem
« on: February 18, 2020, 10:20:56 pm »
Dear all, thanks in advance for any help,

Installed I have FPC 3.3.1, and I've seen lots of threads talking about prblems to load libraries on Raspberry PI 3B

I generated my own libray, that works ok on Win 32 and Linux 32, but when the same application compiled directly on the Raspberry Pi, like the Library, at the Loadlibrary the application simply CLOSE.

I'm already tested with

'./' + Library_Mae
ExtratFilePath(ParamStr(0) + Library_Name

with LoadLbrary,
with safeLoadLibrary

including Initc on the uses clausule

PErmissions on the library was checked too. Then, I'm simply lost.

Obtaining always the same result, application CLOSE without any chance to read Lasterror or other clue to find a solution

here is the problematic part of my code:

Code: Pascal  [Select][+][-]
  1.   if (BV_DLLHandle = 0) AND (Not BV_Dll_Loaded) then
  2.     Begin
  3.       {$IFDEF Linux}
  4.             DLL_BV := './'+DLL_BV;
  5.       {$enid}
  6.        if FileExists(DLL_BV) then
  7.           begin
  8.             try
  9.           //    BV_DLLHandle := safeloadLibrary (DLL_BV)
  10.               BV_DLLHandle := loadLibrary (DLL_BV)  // Here the program literally CLOSE
  11.             except
  12.               on E : exception do
  13.                 begin
  14.                     // LogError;
  15.                 end;
  16.             end;
  17.           end

Other clue was problems to indicate TC_SYSTEM_ISLIBRARY, but theoretically, the problem was solved on 2.7.0

Both parts, Application and library are mine, then any help will be appreciated


TinyPortal © 2005-2018