Recent

Author Topic: Bookmark 0  (Read 425 times)

440bx

  • Hero Member
  • *****
  • Posts: 1876
Bookmark 0
« on: February 16, 2020, 09:09:57 am »
This has probably already been fixed but, just in case, I thought I'd mention it.

The bookmark toggle CTRL-SHIFT <number> works for all numbers except zero (0).

When doing CTRL-SHIFT 0, it doesn't toggle.  Note that I'm using an older version of Lazarus which means this bug may have already been corrected.
FPC v3.0.4 and Lazarus 1.8.2 on Windows 7 64bit.

eljo

  • Sr. Member
  • ****
  • Posts: 407
Re: Bookmark 0
« Reply #1 on: February 16, 2020, 09:17:58 am »
a windows only problem that can be solved by going to the keyboard and language settings and enabling disabling the keystroke for direct selecting of the first language.

440bx

  • Hero Member
  • *****
  • Posts: 1876
Re: Bookmark 0
« Reply #2 on: February 16, 2020, 09:48:36 am »
...solved by going to the keyboard and language settings and enabling disabling the keystroke for direct selecting of the first language.
I appreciate the help but, where is the "keyboard and language settings" ?... I looked in Lazarus and in the Windows Control Panel.  Couldn't find it in either place.
FPC v3.0.4 and Lazarus 1.8.2 on Windows 7 64bit.

Cyrax

  • Hero Member
  • *****
  • Posts: 814
Re: Bookmark 0
« Reply #3 on: February 16, 2020, 09:53:58 am »
...solved by going to the keyboard and language settings and enabling disabling the keystroke for direct selecting of the first language.
I appreciate the help but, where is the "keyboard and language settings" ?... I looked in Lazarus and in the Windows Control Panel.  Couldn't find it in either place.

https://www.eightforums.com/threads/cant-use-ctrl-shift-0-windows-has-it.22552/

Quote
An input method editor (IME) keyboard shortcut lets you switch the input
language. By design, the CTRL+SHIFT+0 key assignment is standard for all
users. However, some applications might use this keyboard shortcut for
other purposes. In this case, the application will not work as expected
when you use the shortcut with the application.

Remove the shortcut assignment to make the application work as expected.
To do this, follow these steps: Click Start, and then click Control
Panel. Double-click Region and Language. Click Keyboards and Languages,
and then click Change keyboards. Click Advanced Key Settings, and select
Between input languages and click change Key Sequence. For Switch Input
Language and for Switch Keyboard Layout, select Not Assigned. Click OK
and the Apply, and the back out clicking OK.

440bx

  • Hero Member
  • *****
  • Posts: 1876
Re: Bookmark 0
« Reply #4 on: February 16, 2020, 09:58:28 am »
That took care of it :) Thank  you Cyrax.
FPC v3.0.4 and Lazarus 1.8.2 on Windows 7 64bit.

 

TinyPortal © 2005-2018