Recent

Author Topic: [SOLVED] Windows 32 bit program does not run - no errors  (Read 378 times)

trev

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1003
  • Former Delphi 1-7, 10.2 User
[SOLVED] Windows 32 bit program does not run - no errors
« on: March 11, 2020, 08:13:28 am »
I compiled the Win32 version of my program on macOS which usually works with no dramas. This time, however, the executable failed to do anything when run on Win32 systems (I tried everything from XP through Win10).

On a wing and a prayer, I compiled a Win64 version. When running this on a Win64 system, I received an access violation error dialog about a method and the program did not run (I chose OK instead of Abort).

Going back to the source, I had a dangling method in the Windows-specific part of the source code. Once I removed that all was well again.

Recorded for posterity lest anyone else encounter this odd phenomenon.
o Lazarus v2.1.0 r63871, FPC v3.3.1 r46876, macOS 10.14.6 (with sup update), Xcode 11.3.1
o Lazarus v2.1.0 r61574, FPC v3.3.1 r42318, FreeBSD 12.1 amd64 (VMware Fusion VM)
o FPC 3.0.4, FreeBSD 12.2-STABLE r365646 amd64
o Lazarus v2.1.0 r61574, FPC v3.0.4, Ubuntu 20.04 (Parallels VM)

 

TinyPortal © 2005-2018