Forum > Editor

I can't change the code editor font in Linux... Anyone?...

<< < (5/5)

Lutz Mändle:
This problem belongs to this bug https://bugs.freepascal.org/view.php?id=36483.
In the bugreport a patch (https://svn.freepascal.org/cgi-bin/viewvc.cgi/trunk/lcl/interfaces/qt5/qtobjects.pas?root=lazarus&r1=62604&r2=62603&pathrev=62604) is mentioned, which fixes the problem.

The problem can circumvented by unsetting the following environment variables:
KDE_FULL_SESSION
DESKTOP_SESSION
XDG_CURRENT_DESKTOP

My desktop link for starting Lazarus contains the following command line:
unset KDE_FULL_SESSION DESKTOP_SESSION XDG_CURRENT_DESKTOP;/usr/bin/startlazarus

This has the side effect, that theme settings for menu shortcuts, system dialogs, colours etc. are not applied.

Navigation

[0] Message Index

[*] Previous page

Go to full version