Forum > Editor

I can't change the code editor font in Linux... Anyone?...

(1/5) > >>


When I change the code editor font, the font picker displays the font correctly but Lazarus uses always the same one, no matter which font I choose. The only thing that changes is the size and spacing.

Check the appended screenshots. You can see that the font I choose is not displayed correctly in the preview of the prefs dialog and in the code editor.

And the font spacing is weird. It's very uncomfortable to work with this font spacing.

Things I've done:

. Tried all the monospace fonts
. Uninstalled Lazarus and installed again, renaming the /home/user_name/.lazarus folder to force a clean one.
. Downgraded linux kernel from 5.4 to 5.3
. Checked font permissions in /usr/share/fonts/
. Upgraded Lazarus 2.0.6 to the last one offered by pacman (25/12/2019)

Nothing works.

The font picker detects the fonts right. And other apps see and use the fonts correctly.

Clearly there is an issue with Lazarus.

System was Manjaro with 5.4 kernel, downgraded to 5.3.
Lazarus version is 2.0.6. (25/12/2019)

Any clues of where to look to fix this?...

Thank you in advance! :)

this topik is old but I've same problem

fonts are weird and there's no way to view a font like in other application
I'm on voidlinux, xfce4

any help is appreciated


tried all monospaced fonts but none of them looks normal

just to show what "weird" means, I attach a screenshot

This malfunction appeared recently, not with a fresh Lazarus install.

Seems to be a problem with the font itself.  Maybe the font file isn't fully compatible or it is old or something.

when installed Lazarus 1st time, display editor was really perfect
after some days, changing font in display option, this probelm appear


[0] Message Index

[#] Next page

Go to full version