Recent

Author Topic: firebird  (Read 598 times)

lawman

  • New Member
  • *
  • Posts: 41
firebird
« on: January 24, 2020, 08:58:10 pm »
Hi,

Just checking which gui you use to create firebird databases and relationships for tables?

made one in open office with relationships, but flamerobin can't seem to open it.

Quote
*** IBPP::SQLException ***
Context: Database::Connect
Message: isc_attach_database failed

SQL Message : -902
Unsuccessful execution caused by a system error that precludes successful execution of subsequent statements

Engine Code    : 335544721
Engine Message :
Unable to complete network request to host "localhost".
Failed to establish a connection.

I haven't installed firebird, which might be really silly of me.   I assumed flamerobin could open without firebird being present.

tried creating one in flame robin but it doesn't let me.

Also, when I did create a database in openoffice, I couldn't create a many to many relationship between 2 tables.     Is this a limitation of firebird?

Thanks

ps.  using linux manjaro
« Last Edit: January 24, 2020, 09:09:44 pm by lawman »

lawman

  • New Member
  • *
  • Posts: 41
Re: firebird
« Reply #1 on: January 24, 2020, 09:17:06 pm »
tried installing firebird and got following errors??

Quote
/run/.../apps.linux/Firebird-3.0.5.33220-0.amd64 >>> sudo ./install.sh      [1]
[sudo] password for adminuser:

Firebird 3.0.5.33220-0.amd64 Installation

Press Enter to start installation or ^C to abort
Archiving...
./usr/include/ibase.h
./usr/include/iberror.h
./usr/include/ib_util.h
usr/lib/libib_util.so
usr/lib/libfbclient.so
usr/lib/libfbclient.so.2
usr/lib/libfbclient.so.2.5.9
Done.
Deleting...
Done.
Extracting install data
tar: ./usr/include/firebird: Cannot open: File exists
tar: Exiting with failure status due to previous errors
Please enter new password for SYSDBA user: xxxxxx
/opt/firebird/bin/gsec: error while loading shared libraries: libtommath.so.0: cannot open shared object file: No such file or directory

Fatal error running 'systemctl --quiet start firebird-superserver.service' - exiting
/run/.../apps.linux/Firebird-3.0.5.33220-0.amd64 >>>     

 

TinyPortal © 2005-2018