Recent

Author Topic: can't run app  (Read 235 times)

madref

  • Hero Member
  • *****
  • Posts: 748
  • ..... A day not Laughed is a day wasted !!
    • Nursing With Humour
can't run app
« on: January 17, 2020, 06:51:13 pm »
I am using Mac OS Mojave. Installed FPC 3.3.1 and Lazarus Trunk version via fpcupdeluxe-x86_64-darwin-cocoa 1.6.6e.


And it doesn't matter which project I am trying to run I get the massage: "Unable to run ....".
I have created the app-bundle.


What am ia doing wrong?
« Last Edit: January 17, 2020, 08:06:00 pm by madref »
You treat a disease, you win, you lose.
You treat a person and I guarantee you, you win, no matter the outcome.

Lazarus 2.0.6 / FPC 3.0.4
Lazarus Trunc / FPC Trunc
Mac OS X Mojave

madref

  • Hero Member
  • *****
  • Posts: 748
  • ..... A day not Laughed is a day wasted !!
    • Nursing With Humour
Re: can't run app
« Reply #1 on: January 17, 2020, 08:16:14 pm »
Strange behaviour of Lazarus Trunk.
When I run the program without debugging I get the error.
But when I run it normal (with debugging) the app just runs
You treat a disease, you win, you lose.
You treat a person and I guarantee you, you win, no matter the outcome.

Lazarus 2.0.6 / FPC 3.0.4
Lazarus Trunc / FPC Trunc
Mac OS X Mojave

trev

  • Sr. Member
  • ****
  • Posts: 407
  • Former Delphi 7 and Delphi 10.2 User
Re: can't run app
« Reply #2 on: January 19, 2020, 06:16:35 am »
I am using Mac OS Mojave. Installed FPC 3.3.1 and Lazarus Trunk version via fpcupdeluxe-x86_64-darwin-cocoa 1.6.6e.

And it doesn't matter which project I am trying to run I get the massage: "Unable to run ....".
I have created the app-bundle.

What am ia doing wrong?

I'm using both Lazarus trunk and FPC trunk and have no issues creating and running applications on macOS Mojave.

Note: I compiled both Lazarus and FPC myself on macOS. I did not install them using fpcdeluxe.
o Lazarus v2.1.0 r62452, FPC v3.3.1 r42644, macOS 10.14.6 (with sup update), Xcode 10.3
o Lazarus v2.1.0 r61574, FPC v3.3.1 r42318, FreeBSD 12.0 (Parallels VM)
o Lazarus v2.1.0 r61574, FPC v3.0.4, Ubuntu 18.04 (Parallels VM)