Forum > Other

Does fpgui still maintained?

<< < (2/4) > >>

guest65109:

--- Quote from: mr.coll on January 05, 2020, 05:43:31 pm ---
--- Quote from: Fred vS on January 05, 2020, 05:30:26 pm ---Hello.

Yes, fpGUI is still maintained:
https://github.com/graemeg/fpGUI/tree/maint

Please, read the INSTALL.txt file, all is explained how to do if you use Lazarus:
https://github.com/graemeg/fpGUI/blob/maint/docs/INSTALL.txt

Fre;D

--- End quote ---

Hi, Fred. Where could I get aggpas? I can't found it under available packages nor Online Package Manager.

--- End quote ---

Finally found it: http://www.crossgl.com/aggpas/

Not updated since 1 October 2009?  :o It seemed to be abandonware. I will not take the risk to install it. My investment on fpgui now considered as a waste of time. I will stop here. Sorry, Fred.

MarkMLl:
Also see https://github.com/CWBudde/AggPasMod

MarkMLl

Fred vS:

--- Quote from: mr.coll on January 05, 2020, 05:43:31 pm ---
--- Quote from: Fred vS on January 05, 2020, 05:30:26 pm ---Hello.

Yes, fpGUI is still maintained:
https://github.com/graemeg/fpGUI/tree/maint

Please, read the INSTALL.txt file, all is explained how to do if you use Lazarus:
https://github.com/graemeg/fpGUI/blob/maint/docs/INSTALL.txt

Fre;D

--- End quote ---

Hi, Fred. Where could I get aggpas? I can't found it under available packages nor Online Package Manager.

--- End quote ---

Aggpas can be used with fpGUI but it is not obliged, it is a fpGUI option for extended design on canvas.
You may also use BGrabitmap, it is fpGUI compatible.

Fre;D

guest65109:

--- Quote from: MarkMLl on January 05, 2020, 06:09:38 pm ---Also see https://github.com/CWBudde/AggPasMod

MarkMLl

--- End quote ---

Thanks for it. Anyway, I compiled the aggpas from lazarus components directory. After that, I could get package fpgui_toolkit.lpk compiled. But Lazarus complains the unit fpg_main is missing, I then do exactly like my first post on this thread, and it ended up exactly the same as my first post already show, it failed to find unit graph even if I add the path to package graph from fpcsrc to Other unit files.

Just a gui toolkit but took too much efforts and finally still can't compile normally. It's a waste of time. It doesn't worth. Don't try this widgetset.

p/s: Sorry, I'm rude again.

guest65109:

--- Quote from: Fred vS on January 05, 2020, 06:18:52 pm ---
--- Quote from: mr.coll on January 05, 2020, 05:43:31 pm ---
--- Quote from: Fred vS on January 05, 2020, 05:30:26 pm ---Hello.

Yes, fpGUI is still maintained:
https://github.com/graemeg/fpGUI/tree/maint

Please, read the INSTALL.txt file, all is explained how to do if you use Lazarus:
https://github.com/graemeg/fpGUI/blob/maint/docs/INSTALL.txt

Fre;D

--- End quote ---

Hi, Fred. Where could I get aggpas? I can't found it under available packages nor Online Package Manager.

--- End quote ---

Aggpas can be used with fpGUI but it is not obliged, it is a fpGUI option for extended design on canvas.
You may also use BGrabitmap, it is fpGUI compatible.

Fre;D

--- End quote ---

But how? How to use BGrabitmap instead of Aggpas? Talk is cheap, show me how. Lazarus showed it's a hard dependency package of fpgui_toolkit.lpk. Without it, the package won't compile. Anyway, I could get over the Aggpas step, the problem now is unit graph, not Aggpas.

p/s: Sorry for being rude.

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version