Recent

Author Topic: fpcdeluxe-x86_64-darwin-cocoa won't let me install fps & Lazarus  (Read 798 times)

madref

  • Hero Member
  • *****
  • Posts: 823
  • ..... A day not Laughed is a day wasted !!
    • Nursing With Humour
fpcdeluxe-x86_64-darwin-cocoa won't let me install fps & Lazarus
« on: December 19, 2019, 12:38:18 pm »
I am trying to install the latest SVN of Lazarus with fpcdeluxe 1.6.6b.
But every time I get this error:
Code: [Select]
fpcupdeluxe: Performing a SVN/GIT/HG/FTP checkout ... please wait, could take some time.
fpcupdeluxe: Start of compile error summary.
fpcupdeluxe: ERROR: FPCNativeInstaller (GetModule: FPC): FPC patching with /Users/madref/fpcupdeluxe/patchfpc/FREEBSDFIXES_FPCPATCH.patch failed.
fpcupdeluxe: Start of compile error summary.
fpcupdeluxe: ERROR: FPCNativeInstaller (GetModule: FPC): FPC patch output: patching file rtl/bsd/ostypes.inc
fpcupdeluxe: Start of compile error summary.
2 out of 3 hunks FAILED -- saving rejects to file rtl/bfpcupdeluxe: ERROR: FPCNativeInstaller (GetModule: FPC): FPC patch output: patching file rtl/bsd/ostypes.inc
fpcupdeluxe: info: FPC native builder: Detected source version FPC: 3.0.4
fpcupdeluxe: info: FPC native builder: Using FPC bootstrap compiler with version: 3.0.2
fpcupdeluxe: Performing a SVN/GIT/HG/FTP checkout ... please wait, could take some time.
fpcupdeluxe: Start of compile error summary.
fpcupdeluxe: ERROR: LazarusNativeInstaller (GetModule: Lazarus): Lazarus patching with /Users/madref/fpcupdeluxe/patchlazarus/DRAGONFLY_LAZPATCH.patch failed.
fpcupdeluxe: Start of compile error summary.
fpcupdeluxe: ERROR: LazarusNativeInstaller (GetModule: Lazarus): Lazarus patch output: patching file components/codetools/definetemplates.pas
fpcupdeluxe: info: Lazarus native builder: Detected source version Lazarus: 2.1.0
fpcupdeluxe: info: Lazarus native builder: Using FPC compiler with version: 3.0.4
fpcupdeluxe: Start of compile error summary.
odetools/definetemplates.pas(323,25) Fatal: (2003) Syntax error, ")" expected but "," found
(3104) Compiling definetemplates.pas
fpcupdeluxe: Start of compile error summary.
Fatal: (1018) Compilation aborted
odetools/definetemplates.pas(323,25) Fatal: (2003) Syntax error, ")" expected but "," found
fpcupdeluxe: Start of compile error summary.
detools/definetemplates.pas(323,25) Fatal: (2003) Syntax error, ")" expected but "," found
Fatal: (1018) Compilation aborted
fpcupdeluxe: Start of compile error summary.
Fatal: (1018) Compilation aborted
detools/definetemplates.pas(323,25) Fatal: (2003) Syntax error, ")" expected but "," found
fpcupdeluxe: Start of compile error summary.
Error: /Users/madref/fpcupdeluxe/fpc/bin/x86_64-darwin/ppcx64 returned an error exitcode
fpcupdeluxe: Start of compile error summary.
fpcupdeluxe: ERROR: LazarusNativeInstaller (BuildModuleCustom: Lazbuild): make returned error code #512
fpcupdeluxe: Done !!
Any suggestions on how to solve this?
You treat a disease, you win, you lose.
You treat a person and I guarantee you, you win, no matter the outcome.

Lazarus 2.0.6 / FPC 3.0.4
Lazarus Trunc / FPC Trunc
Mac OS X Mojave

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1327
Re: fpcdeluxe-x86_64-darwin-cocoa won't let me install fps & Lazarus
« Reply #1 on: December 19, 2019, 01:16:39 pm »
Yes.

Latest version of fpcupdeluxe does patch the sources of Lazarus to enable DragonFly.
However, in the meantime, the maintainers of Lazarus have added DragonFly themselves.
So, fpcupdeluxe does still patch, but this causes problems.

I will update fpcupdeluxe soon, and remove this patch.

StraightFree

  • New Member
  • *
  • Posts: 28
Re: fpcdeluxe-x86_64-darwin-cocoa won't let me install fps & Lazarus
« Reply #2 on: December 19, 2019, 01:48:33 pm »
DonAlfredo and madref,

I have the same problem.

It gives the same error when trying to compile the trunkgit version by FPCUPDeluxe.

Including by guidance of the staff of this topic (https://forum.lazarus.freepascal.org/index.php/topic,47769.15.html) I created an issue on this link (https://github.com/LongDirtyAnimAlf/fpcupdeluxe/issues/167).

Sorry for the question, as this is the first time I have requested this type of correction. How do I know when the fix will be available?

Thanks a lot for the help!

esvignolo

  • Full Member
  • ***
  • Posts: 158
  • Using FPC in Windows, Linux, Macos
Re: fpcdeluxe-x86_64-darwin-cocoa won't let me install fps & Lazarus
« Reply #3 on: December 19, 2019, 09:52:12 pm »
I use de previus version to dragonfly change and work for me.

madref

  • Hero Member
  • *****
  • Posts: 823
  • ..... A day not Laughed is a day wasted !!
    • Nursing With Humour
Re: fpcdeluxe-x86_64-darwin-cocoa won't let me install fps & Lazarus
« Reply #4 on: December 20, 2019, 01:12:01 am »
Solved it by using fpcdeluxe 1.6.4h
You treat a disease, you win, you lose.
You treat a person and I guarantee you, you win, no matter the outcome.

Lazarus 2.0.6 / FPC 3.0.4
Lazarus Trunc / FPC Trunc
Mac OS X Mojave

StraightFree

  • New Member
  • *
  • Posts: 28
Re: fpcdeluxe-x86_64-darwin-cocoa won't let me install fps & Lazarus
« Reply #5 on: December 20, 2019, 04:32:54 pm »
madref,

Thanks for your tip.

Finally I was able to install the version with support for RTTI and Custom Attributes.

Thanks everyone who helped me in some way.

 

TinyPortal © 2005-2018