Recent

Author Topic: Installing RXfpc in Lazarus 2.0.6  (Read 174 times)

MartynA

  • New Member
  • *
  • Posts: 19
Installing RXfpc in Lazarus 2.0.6
« on: November 17, 2019, 05:43:27 pm »
Hello.

I've just installed Lazarus 2.0.6, which seemed to go ok, and am trying to install the RX package rxnew v.1.1.5.98, the latest version I could find into it.

When I try to compile rxnew.lpk, I get a pop-up error message

Broken dependency.

One or more required packages were no found [...]
and the Package Graph popup shows an RXInc rxnew with a red exclamation mark overlaid. The contents of RX.Inc, opened in Notepad, are

{$mode objfpc}
{$H+}

{$DEFINE RX_D3}
{$DEFINE HASVARIANT}
{.$DEFINE ENABLE_Child_Defs}
{$DEFINE NEW_STYLE_TITLE_ALIGNMENT_RXDBGRID}
{$DEFINE RXDBGRID_OPTIONS_WO_CANCEL_ON_EXIT}     

Fwiw, with RX.Inc highlit in the Package editor, the File Properties box is empty.

So, what do I need to fix to get rxnew.lpk to compile?
Btw, apologies for the layout of the above.  I couldn't find  a way in the message editor to indent the quoted parts.

wp

  • Hero Member
  • *****
  • Posts: 6471
Re: Installing RXfpc in Lazarus 2.0.6
« Reply #1 on: November 19, 2019, 06:57:00 pm »
rxnew v1.1.5.98 is extremely old, the version available through OnlinePackageManager (OPM) is v3.3.1.220. If you don't need the latest features of the development version of a package it is always best to install the packages offered by OPM. You find OPM in the menu "Package" of Lazarus.

However, the package rx is indeed broken for Laz 2.0.6, 2.0.4. works -- see also https://forum.lazarus.freepascal.org/index.php/topic,47465.msg339865.
Lazarus trunk / fpc 3.0.4 / all 32-bit on Win-10

lucamar

  • Hero Member
  • *****
  • Posts: 2141
Re: Installing RXfpc in Lazarus 2.0.6
« Reply #2 on: November 19, 2019, 08:05:36 pm »
[...] I couldn't find  a way in the message editor to indent the quoted parts.

See this in the wiki: Forum: Use "code" tags
Turbo Pascal 3 CP/M - Amstrad PCW 8256 (512 KB !!!) :P
Lazarus 2.0.4/2.0.6  - FPC 3.0.4 on:
(K|L)Ubuntu 12..16, Windows XP SP3, various DOSes.