Recent

Author Topic: single unit editing freeze  (Read 308 times)

MSABC

  • New Member
  • *
  • Posts: 38
single unit editing freeze
« on: November 14, 2019, 10:04:19 pm »
Hi all,

what am I doing wrong?

I have a Lazarus Project, running so far. (OK)
I added a new unit (OK)
I worked on the new unit (OK)
Suddenly the source code editor did not respond to any key stroke in that unit any more (NOT OK)
    No characters, no delete, no copy/paste
    Other units (at least the few I checked) can still be edited.

I worked on Lazarus 2.04 on Linux Manjaro 18.3.1
Rebooting did not help.
Update to Lazarus 2.0.6 did not help.

Any hint would be welcome.

Regards 
M.Schäfer

winni

  • Hero Member
  • *****
  • Posts: 609
Re: single unit editing freeze
« Reply #1 on: November 14, 2019, 10:24:24 pm »
Hi!

Change the readonly attribute/flag of the " frozen" file.
For whatever reasons it is set .

Winni

MSABC

  • New Member
  • *
  • Posts: 38
Re: single unit editing freeze
« Reply #2 on: November 14, 2019, 10:31:35 pm »
Hi Winni,

I'm working on a german language set of Lazarus and I am not really sure how to do this.
The unit-selection tabulator at the top of the editor allows the option "Seite sperren" ~"Lock page" (my rough translation).
Maybe you mean this?
The option is not set.
Setting and resetting the option does not help.

Nevertheless, thanks for your help.

M.Schäfer

MSABC

  • New Member
  • *
  • Posts: 38
SOLVED: Re: single unit editing freeze
« Reply #3 on: November 14, 2019, 10:43:18 pm »
I found the attribute with a right button mouse click.
"Darteieinstellungen" "Schreibschutz"

No Idea, why and how I activated this....

@ Winni: I guess you meant this, once again thanks.

M. Schäfer

winni

  • Hero Member
  • *****
  • Posts: 609
Re: single unit editing freeze
« Reply #4 on: November 15, 2019, 01:10:29 am »
Jo, genau das meinte ich!

Winni