Recent

Author Topic: Forum is slow  (Read 1155 times)

winni

  • Hero Member
  • *****
  • Posts: 609
Forum is slow
« on: November 13, 2019, 11:47:43 pm »
Hi!

Why is the forum so slow in the last days???

The browser is waiting and waiting for

http://code.jquery.com/

to answer. Any information out there?

Winni

lainz

  • Hero Member
  • *****
  • Posts: 3324
    • Lainz
Re: Forum is slow
« Reply #1 on: November 14, 2019, 01:00:17 am »
This is in the html page of the forum

Quote
<script src="https://code.jquery.com/jquery-1.10.1.min.js"></script>

But is a CDN, so if you save it it should load from the cache of the browser the next time...

winni

  • Hero Member
  • *****
  • Posts: 609
Re: Forum is slow
« Reply #2 on: November 14, 2019, 01:30:44 am »
@lainz

But it is slow since two or three days - before it was quicker.

Why are things getting worse and not better?

Winni


GAN

  • Full Member
  • ***
  • Posts: 232
Re: Forum is slow
« Reply #3 on: November 14, 2019, 02:57:13 am »
Hi winni, the forum works fine for me, allways. Did you change any settings of your browser?
Lazarus 1.8.4 FPC 3.0.4 Linux Mint Mate 17.2 x86_64 GTK-2
Zeos 7.1.3 - Sqlite 3.8.2

Foro Lazarus en español http://forum.lazarus.freepascal.org/index.php/board,73.0.html

fred

  • Full Member
  • ***
  • Posts: 156
Re: Forum is slow
« Reply #4 on: November 14, 2019, 08:44:58 am »
Here in NL it works as expected.

Quote
Why are things getting worse and not better?
A bit off topic but I agree what is written here:
https://www.smashingmagazine.com/2019/11/online-environments-older-users/
Started with OmegaSoft Pascal on OS-9/68k , now Lazarus 2.0.6 / FPC 3.0.4 on Windows 7

winni

  • Hero Member
  • *****
  • Posts: 609
Re: Forum is slow
« Reply #5 on: November 14, 2019, 10:41:34 am »
Sorry!

It was my incompetent provider!

Winni

willbprog9933

  • Jr. Member
  • **
  • Posts: 53
    • BrainOut!
Re: Forum is slow
« Reply #6 on: November 17, 2019, 12:02:00 am »
Hi everyone,

The site is also getting stuck for me when trying to load the jquery stuff.  Seems like the CDN is having problems or my ISP is throttling it or something...?
Blessed and forgiven! :-D

winni

  • Hero Member
  • *****
  • Posts: 609
Re: Forum is slow
« Reply #7 on: November 17, 2019, 01:45:06 am »
Hi!

The rumours say that a main router in Amsterdam for the traffic to US is broken and slows down
everything.

Perhaps the Dutchmen know a little bit more.

Winni

Thaddy

  • Hero Member
  • *****
  • Posts: 9309
Re: Forum is slow
« Reply #8 on: November 17, 2019, 11:10:53 am »
Perhaps the Dutchmen know a little bit more.
As far as I know AMS-IX is at least triple redundant for all possible SPOF's. So that rumor seems unlikely the case for any reasonable amount of time: should be minutes, not hours.
Also I can't find anything that points to that in the amx-ix logs and statistics (these are public)
also related to equus asinus.

fred

  • Full Member
  • ***
  • Posts: 156
Re: Forum is slow
« Reply #9 on: November 17, 2019, 12:06:29 pm »
I have seen gmail slow recently, simple operations in ms cloud that fail after several minutes because it takes too long.
Perhaps the cloud is breaking up and after that we can see the sun? ::)
Started with OmegaSoft Pascal on OS-9/68k , now Lazarus 2.0.6 / FPC 3.0.4 on Windows 7

lucamar

  • Hero Member
  • *****
  • Posts: 2148
Re: Forum is slow
« Reply #10 on: November 17, 2019, 12:23:25 pm »
In case it matters, I'm in Spain and everything is as quick (or slow, depending on your p.o.v.) as always.
Turbo Pascal 3 CP/M - Amstrad PCW 8256 (512 KB !!!) :P
Lazarus 2.0.4/2.0.6  - FPC 3.0.4 on:
(K|L)Ubuntu 12..16, Windows XP SP3, various DOSes.

willbprog9933

  • Jr. Member
  • **
  • Posts: 53
    • BrainOut!
Re: Forum is slow
« Reply #11 on: November 26, 2019, 09:33:20 pm »
This is still happening a *lot* in the US...

Blessed and forgiven! :-D

Thaddy

  • Hero Member
  • *****
  • Posts: 9309
Re: Forum is slow
« Reply #12 on: November 26, 2019, 09:46:32 pm »
This is still happening a *lot* in the US...
Depends on where you are, but indeed, some parts of the US have extremely slow internet speed compared to western Europe or south-east Asia.
Blame the baby Bell's. It bothers me too every time. Spoils holidays...< >:D> Here in the Netherlands average speed is 100 Mb and fast improving.

Note jquery should be cached in your browser. If you clean the cache too much make an exception for jquery.
« Last Edit: November 26, 2019, 09:52:17 pm by Thaddy »
also related to equus asinus.

willbprog9933

  • Jr. Member
  • **
  • Posts: 53
    • BrainOut!
Re: Forum is slow
« Reply #13 on: November 26, 2019, 09:58:57 pm »
If you clean the cache too much make an exception for jquery.

Thanks for that.  I don't usually clean the cache too often unless Firefox is doing this automatically, but I'll investigate the white-list. :)
Blessed and forgiven! :-D

winni

  • Hero Member
  • *****
  • Posts: 609
Re: Forum is slow
« Reply #14 on: November 26, 2019, 10:23:25 pm »
The funniest thing I heard about how to get an Internet connection comes from Kansas/US:

They make a TCP/IP connection over ham radio. With a Linux kernel driver.

Somewhere documented in the early kernel docs.

It is good that Europe is so small!

Winni