Recent

Author Topic: Installed failed Need Help (Solved)  (Read 254 times)

JLWest

  • Hero Member
  • *****
  • Posts: 614
Installed failed Need Help (Solved)
« on: November 10, 2019, 10:43:11 pm »
So I downloaded and ran the following: -> lazarus-2.0.4-61666-fpc-3.2.0-beta-42593-win64.exe

I get the following error:
 
Directory: C:\lazarus\fpc\3.0.4\source\

Error: directory not found
You can download FPC and the FPC sources from http://sourceforge.net/projects/lazarus/?source=director

As far as "You can download FPC and the FPC sources from http://sourceforge.net/projects/lazarus/?source=directory" I can't find it;


However;  there is a C:\lazarus\fpc\3.2.0\
with a bin/
Doc/
fpmkinst/
msg/
source/
units'

Anybody got any Idea how I get up and running. Do I have to compile something or set a path somewhere?

Thanks

Note: It was looking for 3.04 in the C:\lazarus\fpc\. By setting the compiler path to:

C:\lazarus\fpc\3.2.0\bin\x86_64-win64\fpc.exe seemed to fix it.
« Last Edit: November 10, 2019, 11:00:54 pm by JLWest »
FPC 3.2.0, Lazarus IDE v2.0.4
 Windows 10 Pro 32-GB
 Intel i7 770K CPU 4.2GHz 32702MB Ram
GeForce GTX 1080 Graphics - 8 Gig
4.1 TB

jamie

  • Hero Member
  • *****
  • Posts: 2174
Re: Installed failed Need Help (Solved)
« Reply #1 on: November 10, 2019, 11:16:42 pm »
Looks like it is looking for the version before compiler so it can build the compiler and its sources
on you PC.

 How about you installing the official releases and then install that one afterwards.
Number 1 at blue screen app creations!

JLWest

  • Hero Member
  • *****
  • Posts: 614
Re: Installed failed Need Help (Solved)
« Reply #2 on: November 10, 2019, 11:19:57 pm »
Looks like it is looking for the version before compiler so it can build the compiler and its sources
on you PC.

 How about you installing the official releases and then install that one afterwards.

Yea that would work also.
I have it working now and the program compiled and ran the https perfically

Thanks
FPC 3.2.0, Lazarus IDE v2.0.4
 Windows 10 Pro 32-GB
 Intel i7 770K CPU 4.2GHz 32702MB Ram
GeForce GTX 1080 Graphics - 8 Gig
4.1 TB

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 5801
    • wiki
Re: Installed failed Need Help (Solved)
« Reply #3 on: November 11, 2019, 04:15:07 am »
First of all, do you only want the 3.2 install? Or do you also want the 3.0.4

The installer offers a 2ndary install checkbox, and if checked will ask for a separate dir for the conf, which you could set to an empty folder (even inside the install).

For all else, it knows where your fpc used to be. You can change this either in the setup dialog (if it is showing during startup), or under Tools > Options.

I am not sure why it did not upgrade the version itself.
Also there is a 2.0.6 - 3.2-beta download, but it might have the same issue.

As far as the link goes, not sure why this shows on Windows. It applies to Linux only where fpc is a separate download.
For windows you can download fpc standalone from the fpc site. The Lazarus installers for windows always bundle it into one installer IDE+fpc.
« Last Edit: November 11, 2019, 04:17:46 am by Martin_fr »

JLWest

  • Hero Member
  • *****
  • Posts: 614
Re: Installed failed Need Help (Solved)
« Reply #4 on: November 11, 2019, 04:18:23 pm »
Thnak you. I think I'm good with just the one install of Lazarus and FPC. It seems to be working with 3.2.
FPC 3.2.0, Lazarus IDE v2.0.4
 Windows 10 Pro 32-GB
 Intel i7 770K CPU 4.2GHz 32702MB Ram
GeForce GTX 1080 Graphics - 8 Gig
4.1 TB