Recent

Author Topic: Ambiguous unit found  (Read 405 times)

fmc

  • New Member
  • *
  • Posts: 36
Ambiguous unit found
« on: November 07, 2019, 02:37:08 am »
I have a new install of Lazarus 2.0.6 on Windows 10.  Every time I try to install LAMW from the online package manager's online repo, I get several warnings of ambiguous units, as shown in the pic below. Since these are just warnings, I guess they won't hurt anything. But I abort the process each time just in case it might mess something up. Are these ambiguity warnings normal? I ask because I've rebooted and still get them. 
Win X Pro / Lazarus 2.0.6 / FPC 3.0.4

GetMem

  • Hero Member
  • *****
  • Posts: 3519
Re: Ambiguous unit found
« Reply #1 on: November 07, 2019, 06:15:44 am »
It's just a warning. ServerUtils.pas is used twice in one of the installed packages and the IDE does not like that. You can click the "Ignore all" button and wait until the IDE rebuilds itself. Unfortunately the message pops up each time you (re)install a package, and although harmless, it's kinda annyoing. Ideally should be fixed by the package maintainer.
« Last Edit: November 07, 2019, 06:18:29 am by GetMem »

fmc

  • New Member
  • *
  • Posts: 36
Re: Ambiguous unit found
« Reply #2 on: November 07, 2019, 10:18:53 am »
GetMem: that's the answer I was hoping for. Thanks.
Win X Pro / Lazarus 2.0.6 / FPC 3.0.4