Forum > Embedded - ARM

[LPC1114XL] identifier idents no member [SOLVED]

(1/1)

devport:
Hey,
I programmed LPC1114 and i have XL version 2x SPI.
system library is 1x SPI module (lpc11xx.pp)

I change in lpc11xx.pp TIOCON_Registers record (i added missing code)

--- Code: Pascal  [+][-]window.onload = function(){var x1 = document.getElementById("main_content_section"); if (x1) { var x = document.getElementsByClassName("geshi");for (var i = 0; i < x.length; i++) { x[i].style.maxHeight='none'; x[i].style.height = Math.min(x[i].clientHeight+15,306)+'px'; x[i].style.resize = "vertical";}};} ---    ...    CT16B0_CAP0_LOC : longword;    SCK1_LOC        : longword;    MISO1_LOC       : longword;    MOSI1_LOC       : longword;    CT32B0_CAP0_LOC : longword;    RXD_LOC         : longword;end;... 
In my project i want to use  "LPC_IOCON.MISO1_LOC := $01; " but i get a error.

I compile again all modules from fpc source, but not working.
Lazarus always show this error.

All module lpc11xx.pp in lazarus and fpc src. have new changes.

I found a solution, I used the cross compiler from the old FPC installation.
All modules used in process compile they were in the old location (C:/FPC/...)

Problem is solved, but auto appending modules (lpc11xx.pp) from fpc/source is wrong solution.
This unit should be used in the project directory.

Best regards!
Darek

Navigation

[0] Message Index

Go to full version