Author Topic: [LPC1114XL] identifier idents no member [SOLVED]  (Read 777 times)


  • New Member
  • *
  • Posts: 26
[LPC1114XL] identifier idents no member [SOLVED]
« on: November 06, 2019, 09:16:51 am »
I programmed LPC1114 and i have XL version 2x SPI.
system library is 1x SPI module (lpc11xx.pp)

I change in lpc11xx.pp TIOCON_Registers record (i added missing code)
Code: Pascal  [Select][+][-]
  1.     ...
  2.     CT16B0_CAP0_LOC : longword;
  3.     SCK1_LOC        : longword;
  4.     MISO1_LOC       : longword;
  5.     MOSI1_LOC       : longword;
  6.     CT32B0_CAP0_LOC : longword;
  7.     RXD_LOC         : longword;
  8. end;
  9. ...

In my project i want to use  "LPC_IOCON.MISO1_LOC := $01; " but i get a error.

I compile again all modules from fpc source, but not working.
Lazarus always show this error.

All module lpc11xx.pp in lazarus and fpc src. have new changes.

I found a solution, I used the cross compiler from the old FPC installation.
All modules used in process compile they were in the old location (C:/FPC/...)

Problem is solved, but auto appending modules (lpc11xx.pp) from fpc/source is wrong solution.
This unit should be used in the project directory.

Best regards!
« Last Edit: November 06, 2019, 12:02:02 pm by devport »


TinyPortal © 2005-2018