Recent

Author Topic: Double click in TListBox to do ShowModal causes loss of focus  (Read 371 times)

bigDan

  • New Member
  • *
  • Posts: 37
Double click in TListBox to do ShowModal causes loss of focus
« on: November 03, 2019, 06:45:09 pm »
Here is the second problem I hit when trying to convert from macOS/64bit/QT5 to cocoa.

The sequence of events is:

  • Double click in a TListBox
  • Display another form via showmodal
  • Exit the showmodal form

At this point, the original form with the TListBox is displayed but the keyboard no longer works (focus lost?). You cannot use arrows, tab, escape. Nothing appears to work.

If you use the mouse, the first click is ignored. Click again and then the first click is registered.

To replicate this error in the attached project:

  • In FormA click DoIt
  • In FormB double click "Double Click Test1"
  • In FormC press ESC or click on Exit

At this point you should be able to press ESC to return to FormA. That does not work. In fact nothing seems to work using the keyboard.

Further, if you click on exit, the button is highlighted, but no exit occurs. Now click anywhere in the form and the exit will occur.

Note that if, in FormB you click on DoIt or Click on "Single Click Test" TListBox, the problem will not occur.

bigDan

  • New Member
  • *
  • Posts: 37
Re: Double click in TListBox to do ShowModal causes loss of focus
« Reply #1 on: November 05, 2019, 10:59:05 pm »
Now in bug tracker as issue 0036266.

bigDan

  • New Member
  • *
  • Posts: 37
Re: Double click in TListBox to do ShowModal causes loss of focus
« Reply #2 on: November 06, 2019, 06:45:10 pm »
Fixed in 62204