Recent

Author Topic: Lazarus Release 2.0.6  (Read 21079 times)

laguna

  • Sr. Member
  • ****
  • Posts: 274
Re: Lazarus Release 2.0.6
« Reply #60 on: November 13, 2019, 01:09:27 pm »
This versione is not compatible with Catalina 64bit.

I install the files from https://sourceforge.net/projects/lazarus/files/Lazarus%20macOS%20x86-64/

installation is abort for this programs: LazarusIDE-2.0.6-macos-x86_64.pkg  and fpc-3.0.4-macos-x86_64-laz.pkg

XCode is installated

Please Help Me.

Thanks
LaGuNa

Rainbow6

  • New Member
  • *
  • Posts: 11
Re: Lazarus Release 2.0.6
« Reply #61 on: November 13, 2019, 03:05:34 pm »
Try using FPCUpDeluxe and install in a user folder.

And you have to switch off GateKeeper.

willbprog9933

  • Jr. Member
  • **
  • Posts: 53
    • BrainOut!
Re: Lazarus Release 2.0.6
« Reply #62 on: November 13, 2019, 09:58:04 pm »
This versione is not compatible with Catalina 64bit.

Try using FPCUpDeluxe and install in a user folder.
And you have to switch off GateKeeper.

I am on Catalina and this is very frustrating for me.  I know this is not a paid product and that the developers are doing what they can, but I think that...
  • Lazarus can no longer be called cross-platform for the current macOS (Catalina/10.15.x)
  • There should be a clear warning when attempting to download the macOS version that it's not yet compatible with Catalina
  • macOS Catalina users shouldn't have to trust/rely on some questionable and ill-functioning third-party software to install Lazarus/FPC

This stinks for everyone who wants to use Lazarus/FPC on Catalina.  :'(
Blessed and forgiven! :-D

mattias

  • Administrator
  • Full Member
  • *
  • Posts: 150
    • http://www.lazarus.freepascal.org
Re: Lazarus Release 2.0.6
« Reply #63 on: November 14, 2019, 07:07:22 am »
This versione is not compatible with Catalina 64bit.

 :o

I created and tested it on Catalina.

I install the files from https://sourceforge.net/projects/lazarus/files/Lazarus%20macOS%20x86-64/

installation is abort for this programs: LazarusIDE-2.0.6-macos-x86_64.pkg  and fpc-3.0.4-macos-x86_64-laz.pkg

Were you able to install fpc-3.0.4-macos-x86_64-laz.pkg ?

Are there any error messages in /var/log/install.log?

Mattias

Thaddy

  • Hero Member
  • *****
  • Posts: 9293
Re: Lazarus Release 2.0.6
« Reply #64 on: November 14, 2019, 07:47:15 am »
[[/li][li]There should be a clear warning when attempting to download the macOS version that it's not yet compatible with Catalina[/li][/list]
[
What *exactly* are the problems, because I can not reproduce them...(I did not test cross- compilation yet)
also related to equus asinus.

willbprog9933

  • Jr. Member
  • **
  • Posts: 53
    • BrainOut!
Re: Lazarus Release 2.0.6
« Reply #65 on: November 14, 2019, 08:11:13 am »
Were you able to install fpc-3.0.4-macos-x86_64-laz.pkg ?

Are there any error messages in /var/log/install.log?

Installing the latest FPC does not work.  It fails with the error: "Install failed. The installer encountered an error that caused the install to fail."

The installer log says this:

Code: [Select]
Nov 13 23:06:31 Mac-mini-2018 Installer[1598]: @(#)PROGRAM:Install  PROJECT:Install-1000
Nov 13 23:06:31 Mac-mini-2018 Installer[1598]: @(#)PROGRAM:Installer  PROJECT:Installer-965.1
Nov 13 23:06:31 Mac-mini-2018 Installer[1598]: Hardware: Macmini8,1 @ 3.20 GHz (x 12), 16384 MB RAM
Nov 13 23:06:31 Mac-mini-2018 Installer[1598]: Running OS Build: Mac OS X 10.15.1 (19B88)
Nov 13 23:06:31 Mac-mini-2018 Installer[1598]: fpc-macos-x86-64-laz  Installation Log
Nov 13 23:06:31 Mac-mini-2018 Installer[1598]: Opened from: /Users/will/Downloads/fpc-3.0.4-macos-x86_64-laz.pkg
Nov 13 23:06:31 Mac-mini-2018 Installer[1598]: Package Authoring Error: <background_scaling> has an unsupported MIME type: X-NSObject/NSNumber
Nov 13 23:06:31 Mac-mini-2018 Installer[1598]: Package Authoring Error: <background_alignment> has an unsupported MIME type: X-NSObject/NSNumber
Nov 13 23:06:31 Mac-mini-2018 Installer[1598]: Package Authoring Error: <layout-direction> has an unsupported MIME type: X-NSObject/NSNumber
Nov 13 23:06:31 Mac-mini-2018 Installer[1598]: Failed to load specified background image
Nov 13 23:06:31 Mac-mini-2018 Installer[1598]: Could not load resource readme: (null)
Nov 13 23:06:43 Mac-mini-2018 Installer[1598]: ================================================================================
Nov 13 23:06:43 Mac-mini-2018 Installer[1598]: User picked Standard Install
Nov 13 23:06:43 Mac-mini-2018 Installer[1598]: Choices selected for installation:
Nov 13 23:06:43 Mac-mini-2018 Installer[1598]: Install: "fpc-macos-x86-64-laz"
Nov 13 23:06:43 Mac-mini-2018 Installer[1598]: Install: "fpc-macos-x86-64-laz"
Nov 13 23:06:43 Mac-mini-2018 Installer[1598]: ================================================================================
Nov 13 23:06:43 Mac-mini-2018 Installer[1598]: Configuring volume "macOS SSD"
Nov 13 23:06:43 Mac-mini-2018 Installer[1598]: Free space on "macOS SSD": 155.46 GB (155457888256 bytes).
Nov 13 23:06:43 Mac-mini-2018 Installer[1598]: Create temporary directory "/var/folders/dn/2kt85pb54pbf4yff9_62070m0000gp/T//Install.1598Zrixdd"
Nov 13 23:06:43 Mac-mini-2018 Installer[1598]: IFPKInstallElement (1 packages)
Nov 13 23:06:43 Mac-mini-2018 Installer[1598]: PackageKit: Enqueuing install with framework-specified quality of service (utility)
Nov 13 23:06:43 Mac-mini-2018 installd[1222]: PackageKit: ----- Begin install -----
Nov 13 23:06:48 Mac-mini-2018 installd[1222]: PackageKit: Install Failed: Error Domain=PKInstallErrorDomain Code=112 "An error occurred while running scripts from the package “fpc-3.0.4-macos-x86_64-laz.pkg”." UserInfo={NSFilePath=./postinstall, NSURL=file:///Users/will/Downloads/fpc-3.0.4-macos-x86_64-laz.pkg#fpc-macos-x86-64-laz.pkg, PKInstallPackageIdentifier=org.freepascal.pkg.fpc-macos-x86-64-laz, NSLocalizedDescription=An error occurred while running scripts from the package “fpc-3.0.4-macos-x86_64-laz.pkg”.} {
    NSFilePath = "./postinstall";
    NSLocalizedDescription = "An error occurred while running scripts from the package \U201cfpc-3.0.4-macos-x86_64-laz.pkg\U201d.";
    NSURL = "file:///Users/will/Downloads/fpc-3.0.4-macos-x86_64-laz.pkg#fpc-macos-x86-64-laz.pkg";
    PKInstallPackageIdentifier = "org.freepascal.pkg.fpc-macos-x86-64-laz";
}
Nov 13 23:06:48 Mac-mini-2018 Installer[1598]: Install failed: The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.
Nov 13 23:06:48 Mac-mini-2018 Installer[1598]: IFDInstallController 33B2B80 state = 8
Nov 13 23:06:48 Mac-mini-2018 Installer[1598]: Displaying 'Install Failed' UI.
Nov 13 23:06:48 Mac-mini-2018 Installer[1598]: 'Install Failed' UI displayed message:'The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.'.
Blessed and forgiven! :-D

willbprog9933

  • Jr. Member
  • **
  • Posts: 53
    • BrainOut!
Re: Lazarus Release 2.0.6
« Reply #66 on: November 14, 2019, 08:16:29 am »
What *exactly* are the problems, because I can not reproduce them...(I did not test cross- compilation yet)

It doesn't install.  That's a pretty big problem. :P
Blessed and forgiven! :-D

Thaddy

  • Hero Member
  • *****
  • Posts: 9293
Re: Lazarus Release 2.0.6
« Reply #67 on: November 14, 2019, 10:22:51 am »
Then why do I have it running? And Matthias too? (native, not a VM) Can you check at least your install.log
Quote
It doesn't install.  That's a pretty big problem. :P
on its own is not very helpful.

But maybe a case of https://blog.codinghorror.com/the-works-on-my-machine-certification-program/ :
« Last Edit: November 14, 2019, 10:29:27 am by Thaddy »
also related to equus asinus.

mattias

  • Administrator
  • Full Member
  • *
  • Posts: 150
    • http://www.lazarus.freepascal.org
Re: Lazarus Release 2.0.6
« Reply #68 on: November 14, 2019, 12:27:43 pm »
Installing the latest FPC does not work.  It fails with the error: "Install failed. The installer encountered an error that caused the install to fail."

Note for others: This is not an official FPC release. I repackaged it using the x86-64 files from the FPC 3.0.4a release.

About:
...Nov 13 23:06:31 Mac-mini-2018 Installer[1598]: Failed to load specified background image
Nov 13 23:06:31 Mac-mini-2018 Installer[1598]: Could not load resource readme: (null)...

That's normal, I didn't specify a background image, nor a readme.

Did you run in a terminal before installing:
xcode-select --install
?

Mattias

laguna

  • Sr. Member
  • ****
  • Posts: 274
Re: Lazarus Release 2.0.6
« Reply #69 on: November 14, 2019, 12:40:21 pm »
Mattias, please test "Lazarus" in new machine with Catalina!

I installed  in new machine 
1) Catalina
2) XCode
3) Tools XCode
4) Down files Lazarus

This Errore when installed "Installing the latest FPC does not work"

Thanks
LaGuNa



mattias

  • Administrator
  • Full Member
  • *
  • Posts: 150
    • http://www.lazarus.freepascal.org
Re: Lazarus Release 2.0.6
« Reply #70 on: November 14, 2019, 12:43:39 pm »
Mattias, please test "Lazarus" in new machine with Catalina!

Where/how can I get a new machine?

I installed  in new machine 
3) Tools XCode

Did you do "xcode-select --install"?

willbprog9933

  • Jr. Member
  • **
  • Posts: 53
    • BrainOut!
Re: Lazarus Release 2.0.6
« Reply #71 on: November 14, 2019, 06:18:08 pm »
Did you run in a terminal before installing:
xcode-select --install
?

In my case, yes.  I use the xcode command-line tools for other things, as well.
Blessed and forgiven! :-D

willbprog9933

  • Jr. Member
  • **
  • Posts: 53
    • BrainOut!
Re: Lazarus Release 2.0.6
« Reply #72 on: November 14, 2019, 06:19:26 pm »
Note for others: This is not an official FPC release. I repackaged it using the x86-64 files from the FPC 3.0.4a release.

My attempt at installing came directly from SourceForge.  Did you post a link for a special package?

Thanks :)
Blessed and forgiven! :-D

laguna

  • Sr. Member
  • ****
  • Posts: 274
Re: Lazarus Release 2.0.6
« Reply #73 on: November 15, 2019, 08:22:53 am »
Mattias, please  view images attachments.

Thanks.

laguna

  • Sr. Member
  • ****
  • Posts: 274
Re: Lazarus Release 2.0.6
« Reply #74 on: November 15, 2019, 10:11:53 am »

I did it like this:

Download Release v1.6.4d of fpcupdeluxe-x86_64-darwin-cocoa.zip

this file not have permiss for excecute

cd  fpcupdeluxe-x86_64-darwin-cocoa.app/Contents/MacOS
sudo chmod +x fpcupdeluxe-x86_64-darwin-cocoa

run fpcupdeluxe-x86_64-darwin-cocoa.app   
but not correct show setting
abort run fpcupdeluxe-x86_64-darwin-cocoa.app   

open folder  fpcupdeluxe-x86_64-darwin-cocoa.app/Contents/MacOS
and run with mouse fpcupdeluxe-x86_64-darwin-cocoa

Run is OK

Setting in cross CPU x86_64  and in OS Darwin
finally install fpc stable version

(Lazarus not install of fpcudeluxe)

Lazarus install with source code
in catalina not write in /usr/lib
for write
sudo mount -uw /

sudo ln -s /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX.sdk/usr/lib/crt1.10.5.o  /usr/lib/crt1.10.5.o

cd fpcupdeluxe
mkdir lazarus
cd lazarus
svn checkout https://svn.freepascal.org/svn/lazarus/branches/fixes_2_0 laz_fixes
// wait some time ....
cd laz_fixes
make LCL_PLATFORM=cocoa CPU_TARGET=x86_64 bigide
// wait some time .....
open startlazarus.app --args "--pcp=~/.laz_fixes"

Running

LaGuNa