Recent

Author Topic: Unable to lunch lazarus  (Read 9112 times)

bijop

  • Newbie
  • Posts: 2
Unable to lunch lazarus
« on: September 18, 2004, 12:44:57 am »
The first time I have succeded in compilation then ran Lazarus, everythings was fine : WAOU, Delphi under MAC OS X,  great news ....

I begun to configure paths of the fpc source and compiler etc ...
I think I gave a bad path for the ppc (?), and now lazarus give me this error at lunch time with an error form (access violation just after the lazarus logo) :

Gdk-ERROR **: BadIDChoice (invalid resource ID chosen for this connection)
  serial 1763 error_code 14 request_code 1 minor_code 0
Gdk-ERROR **: BadWindow (invalid Window parameter)
  serial 1764 error_code 3 request_code 2 minor_code 0

Is there a configuration file I can change ?

THANKS A LOT FOR DOING THIS MARVELLOUS PROJECT !
Best regards,
bijop

Marc

  • Administrator
  • Hero Member
  • *
  • Posts: 2496
Unable to lunch lazarus
« Reply #1 on: September 18, 2004, 07:44:28 pm »
The good news, I don't think this is a problem of the compiler
The bad news, we sometimes see this also on Linux (the X server complaining about async replies).
I don't have a Mac but the types of gtk errors look the same.
Sometimes recompilation or some codechanges triggered it for me and the next time it was gone.
You can try to rebuild
//--
{$I stdsig.inc}
//-I still can't read someones mind
//-Bugs reported here will be forgotten. Use the bug tracker

Carbonide

  • New Member
  • *
  • Posts: 15
Unable to lunch lazarus
« Reply #2 on: September 20, 2004, 11:29:01 pm »
Well, I have another problem: I downloaded and installed fpc and then installed lazarus by using make. I launched lazarus and set the path to fpc (/usr/local/bin). When trying to compile a program, it tells me that the "Free Pascal source directory was not found". I don't know where to download or install that. The installer for fpc for OS X only installs the binary it seems.

Any help would be greatly appreciated.

MrBob

  • Newbie
  • Posts: 1
Unable to lunch lazarus
« Reply #3 on: September 21, 2004, 04:45:26 am »
Carbonide: Though I don't have OS X (Though I want a Powerbook :-) ), this works on GNU/Linux.

First, Download the latest FPC source. Second, extract it. Next, goto "Enviroment Options" in the Enviroment menu, and enter the directory with the unextracted files as the "FPC source directory".

That's it! It should work now.

Sorry if that sounded out of tough, it is pretty late... Please reply if you need anything else.

Thanks :D

Carbonide

  • New Member
  • *
  • Posts: 15
Unable to lunch lazarus
« Reply #4 on: September 21, 2004, 02:25:03 pm »
Hey, MrBob, that was too easy :)

I'm happy to report that Lazarus works perfectly now (incidentally, on my PowerBook) on Mac OS X.

Go get a Powerbook, OS X + Lazarus = happiness :)

Thanks for your help and a big thank you to everyone involved in the development of Lazarus!

bijop

  • Newbie
  • Posts: 2
Unable to lunch lazarus
« Reply #5 on: September 25, 2004, 04:33:19 pm »
Just if somebody get the problem (Gdk error ... cf my first mail on Sept 17 2004) :

if you delete every files wich are in the .lazarus of your home directory (you must be root to see it),
then lazarus will work fine ... but don't ask me why (it would mean that it was realy a problem with
config files ... ????).

bijop, :)

Anonymous

  • Guest
Unable to lunch lazarus
« Reply #6 on: December 11, 2004, 02:20:16 pm »
Quote from: "bijop"

if you delete every files wich are in the .lazarus of your home directory (you must be root to see it),


As non-root, you can use the "Go to Folder..." command of the finder (in the Go menu or cmd-shift-g), then type "~/.lazarus".

Or use Terminal.