Recent

Author Topic: Warning about Upgrade to Ubuntu19.10  (Read 164 times)

Zvoni

  • Sr. Member
  • ****
  • Posts: 301
Warning about Upgrade to Ubuntu19.10
« on: October 23, 2019, 09:16:22 am »
hi Folks,

be careful, when upgrading to Ubuntu19.10
If you're using MySQL5.7 (or lower), don't forget to lock your mysql-versions in Synaptic.
It happened to me yesterday late in the evening (being half asleep), i kicked off the upgrade,
and when i read the summary what was installed resp. removed i started cursing like a sailor, when i read
"mysql5.7 community edition being removed, mysql8 being installed"
it doesn't matter if it's the MySQl from the Dist-Repo, or the one from the MySQL-Repo.
Not  locked = MySQL5.X removed/replaced with MySQL8

I lucked out, that my Laptop is "just" a dev-machine (with no running live-DB's on it), so i don't lose anything with removing MySQL8, and reinstalling MySQL5.X again
but i have another Ubuntu19.04-Machine with a Live MySQL5.7 on it......
One System to rule them all, One IDE to find them,
One Code to bring them all, and to the Framework bind them,
in the Land of Redmond, where the Windows lie
---------------------------------------------------------------------
People call me crazy, because i'm jumping out of perfectly fine aircrafts