Recent

Author Topic: WSLazWebkitSettings.pp(49,1) Fatal: Syntax error, "identifier" expected but "PRO  (Read 270 times)

23 __________)

  • New member
  • *
  • Posts: 5
(https://i.ibb.co/c16mMy3/Capture.png)
« Last Edit: October 20, 2019, 06:29:19 pm by 23 __________) »

marcov

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7503
Seems that code only assumes GTK2 as backend.

23 __________)

  • New member
  • *
  • Posts: 5
How do I fix it?

I am trying to install HTMLViewer-119 that is in the Webbrowser links page on freepascal.org
and
it is not working and it should be

23 __________)

  • New member
  • *
  • Posts: 5
it happens when I'm trying to install all packages

marcov

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7503
Remove the "uses" line too, just before the ifdef lcl_gtk2. But this also means that other combinations are probably untested

23 __________)

  • New member
  • *
  • Posts: 5
that didn't work for me

23 __________)

  • New member
  • *
  • Posts: 5
How do I fix this?
Why wouldn't it be happening with other lazurus installations?