Recent

Author Topic: XMailer Installation Failure  (Read 738 times)

Razmataz2

  • New member
  • *
  • Posts: 9
XMailer Installation Failure
« on: October 15, 2019, 04:07:23 am »
I'm trying to install XMailer from the repository via the Online Package Manager. Synapse is a dependency, and the installer is successful in downloading, opening, and compiling that package. Xmailer, however, fails with a "Fatal: Cannot find SSL_OpenSSL used by XMailer of package XMailerPkg."  I'm running Ubuntu 19.04 and ensured that I had openssl and libssl-dev (1.1.1b-1ubuntu2.4) installed before attempting to install XMailer.

Thoughts on resolving this issue?

Thanks!

trev

  • Full Member
  • ***
  • Posts: 220
  • Former Delphi 7 and Delphi 10.2 User
Re: XMailer Installation Failure
« Reply #1 on: October 16, 2019, 09:35:38 am »
Duplicate post of the extensive discussion at https://forum.lazarus.freepascal.org/index.php/topic,47082.0.html
o Lazarus v2.1.0 r61775, FPC v3.3.1 r42640, macOS 10.14.6 (with sup update), Xcode 10.3
o Lazarus v2.1.0 r61574, FPC v3.3.1 r42318, FreeBSD 12.0 (Parallels VM)
o Lazarus v2.1.0 r61574, FPC v3.0.4, Ubuntu 18.04 (Parallels VM)