Recent

Author Topic: SynEdit register double characters when typing  (Read 261 times)

ccrause

  • Full Member
  • ***
  • Posts: 183
SynEdit register double characters when typing
« on: September 22, 2019, 12:20:29 pm »
I have encountered a strange problem with SynEdit, when typing in a SynEdit, such as the Lazarus editor (and also one of the SynEdit demos) it displays each character typed on the keyboard as double characters.  I see no similar effects in other components such as TMemo, or other software such as Xed, Libre Office, this edit window in Firefox etc.

The problem started after I rebooted after updating Linux Mint.  I've tried rolling back to a past snapshot when everything worked fine, but no luck.  I also upgraded to the latest Linux Mint 19.2, but same issue.

System: Linux Mint Mate 19.1 & 19.2. GTK2, Lazarus: latest trunk (r61909) and also Lazarus 1.8.2 (worked before).  I think this problem made a brief appearance some time ago, but somehow it went away (hazy memory...).

I worked around the issue for now by switching to QT.

Any thoughts on how to get SynEdit working properly with GTK2?

Thaddy

  • Hero Member
  • *****
  • Posts: 8954
Re: SynEdit register double characters when typing
« Reply #1 on: September 22, 2019, 12:30:43 pm »
No thoughts about fixing it, but I remember something similar regularly occurs on Mint. (NOT only Lazarus). Search the forum. AFAIK it does not go away easily....

(Unless there  were some flaming Mint users maybe...)
« Last Edit: September 22, 2019, 12:33:21 pm by Thaddy »
Most people that want to use threading should learn to patch their jeans first: use a needle.

howardpc

  • Hero Member
  • *****
  • Posts: 3153
Re: SynEdit register double characters when typing
« Reply #2 on: September 22, 2019, 12:47:09 pm »

ccrause

  • Full Member
  • ***
  • Posts: 183
Re: SynEdit register double characters when typing
« Reply #3 on: September 22, 2019, 01:20:15 pm »
See this for a solution

Thank you howardpc, those recommendations fixed my problem.

Thaddy, you were correct.  Quite a few hits if one knows what search phrases to use.

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 5635
    • wiki
Re: SynEdit register double characters when typing
« Reply #4 on: September 22, 2019, 01:22:35 pm »
If this is typing ONE "M" will display "MM" => see howardpc

If that is typing one "M" will display one "M" but with extra space to the next/previous char:
- Use a strict monospaced font.
- Or set ExtraSpacing[BetweenChars]. You will need a negative value in this case. And it will have side effects, as some chars will need the full space (try the "@" symbol)

ccrause

  • Full Member
  • ***
  • Posts: 183
Re: SynEdit register double characters when typing
« Reply #5 on: September 22, 2019, 01:46:19 pm »
If this is typing ONE "M" will display "MM" => see howardpc

My problem was indeed of that kind: qwerty => qqwweerrttyy

ccrause

  • Full Member
  • ***
  • Posts: 183
Re: SynEdit register double characters when typing
« Reply #6 on: September 22, 2019, 03:12:11 pm »
After some looking around I found the root of the problem (input method as mentioned in the wiki).  In my case (Linux Mint Mate) the setting can be seen/changed here: Menu - Preferences - Input method, then set Input method framework to None to change it system wide (remember to reboot).