Recent

Author Topic: Cannot build with BGRA controls installed.  (Read 419 times)

metal mark

  • New Member
  • *
  • Posts: 38
Cannot build with BGRA controls installed.
« on: September 26, 2019, 10:08:22 pm »
I have been trying for days now to load lazarus onto my Rpi. Using the normal apt-get for fpc and lazarus and setting the swap file to 2000 and adding the extra libraries I get a working version of Lazarus.  However the controls I want to use are in BGRA Controls, now comes the problem , I have installed fpdebug as it keeps saying lazarus can't find it. So having installed it through the online package manager I then install BGRA Controls with its dependencies and I get 'success' for everything. It now asks if I want to build lazarus which I hope will then show the BGRA as available. Sadly no , once again it says lazarus.pp can't find fpdebug.  I am truly fed up now. I have done all this on my lap top and it works perfectly but as soon as I do it on my RPi it all goes to pot  %). Help please.
Thanks MM

winni

  • Sr. Member
  • ****
  • Posts: 415
Re: Cannot build with BGRA controls installed.
« Reply #1 on: September 26, 2019, 11:10:51 pm »
Hi!

So let's check the state of your BGRAControls:

Main Menu --> Package --> Configure installed packages (second last item)

Now the package dialog appears.

Is BGRAControls in the left Listbox??

If yes click once on it.  At the bottom is the memo field with the package info.
In the last line the status is reported.
Is it installed?

Please report this and then we can continue.

Winni

metal mark

  • New Member
  • *
  • Posts: 38
Re: Cannot build with BGRA controls installed.
« Reply #2 on: September 26, 2019, 11:31:55 pm »
Thank you for replying.
Bgracontrols 6.5 is showing in the left box.
The package info  says current state :not installed, runand designtime

winni

  • Sr. Member
  • ****
  • Posts: 415
Re: Cannot build with BGRA controls installed.
« Reply #3 on: September 26, 2019, 11:57:09 pm »
Hi!

So click in the package dialog on the middle button at the bottom "Save and compile IDE". And sit back a minute. More or less - depends on the speed of your PC.

Then the IDE is restarted. Now you should have two new riders in the component palette: "BGRA Controls" and "BGRA Button Controls"  - not visible at the right side. You have to scroll right.

Hope it works!

Winni

metal mark

  • New Member
  • *
  • Posts: 38
Re: Cannot build with BGRA controls installed.
« Reply #4 on: September 27, 2019, 12:21:50 am »
Unfortunately not, get the same message :-
Build IDE:Exir code 2, Errors :1
Lazarus.pp(1,1) Fatel: Cannot find fpdebug used by lazarus.

metal mark

  • New Member
  • *
  • Posts: 38
Re: Cannot build with BGRA controls installed.
« Reply #5 on: September 27, 2019, 12:27:19 am »
I now find that fpdebug is also in the left column ready to install but showing as not installed. So it looks like I can't install fpdebug because it can't find fpdebug to allow me to install it  %). I am truly lost.
« Last Edit: September 27, 2019, 12:29:29 am by metal mark »

winni

  • Sr. Member
  • ****
  • Posts: 415
Re: Cannot build with BGRA controls installed.
« Reply #6 on: September 27, 2019, 12:45:46 am »
Hi!

So now we deselect the debugger:

Package  dialog, mark the fpdebug, press the first button below the left listbox "deselect selection". fpcdeg should vanish in the left listbox and appear in the right one.
And now again: Press the middle button at the bottom "Save and compile the IDE".

Hope it helps. 

Winni

metal mark

  • New Member
  • *
  • Posts: 38
Re: Cannot build with BGRA controls installed.
« Reply #7 on: September 27, 2019, 09:23:31 am »
Just the same error message. 'Cannot find fpdebug used by Lazarus'.  :(

metal mark

  • New Member
  • *
  • Posts: 38
Re: Cannot build with BGRA controls installed.
« Reply #8 on: September 27, 2019, 01:28:02 pm »
Well , having done some more digging it would seem that the repository fpc is either broken or not compatible with the repository lazarus download or with the latest raspbian Noobs download.

metal mark

  • New Member
  • *
  • Posts: 38
Re: Cannot build with BGRA controls installed.
« Reply #9 on: September 28, 2019, 05:07:41 pm »
I loaded 'stretch' last night and reloaded fpc and lazerus. Whoopee I could rebuild with no errors  :D Sadly there is no online package manager to download BGRA controls so back to square one  %). Lazarus is such a brilliant GUI IDE but at times it is so frustrating.  I'm going to swear now, I downloaded CodeTyphon onto my RPI last night and it works and it has BGRA controls built in but it is so slow as to be useless. Well fed up  :(