Recent

Author Topic: Problems Installing a Package.  (Read 255 times)

sergioantonio2013

  • New Member
  • *
  • Posts: 22
Problems Installing a Package.
« on: September 13, 2019, 10:50:42 pm »
I am trying to install the lazVLC package, I am using Lazarus 2.0.2.
I go under Package -> Install/uninstall packages
I select LazLVC 1.0  and click on Install Selection.
I then click on the Save and Rebuild IDE button.
It gives me the following error:

Lazarus.pp(57,3) Fatal: Cannot find Interfaces used by Lazarus, incompatible ppu=C:\lazarus\lcl\units\i386-win32\win32\interfaces.ppu, package  LCL

the source code to interface.pp is in the folder:

C:\lazarus\lcl\interfaces\win32

any help on getting the IDE to rebuild without errors?

Thanks

« Last Edit: September 13, 2019, 11:17:27 pm by sergioantonio2013 »

wp

  • Hero Member
  • *****
  • Posts: 6495
Re: Problems Installing a Package.
« Reply #1 on: September 13, 2019, 11:08:37 pm »
I just tried it with Laz 2.0.2 / Win10, and the installation runs correctly.

If these kind of error happens there is somewhere an out-dated compiled unit for which the compiler does not find the sources. It usually helps to go to "Tools" > "Configure Build Lazarus", check "Clean all" and "Switch after building to automatically" and press "Build". This erases all compiled units and rebuilds everything from the start.
Lazarus trunk / fpc 3.0.4 / all 32-bit on Win-10

sergioantonio2013

  • New Member
  • *
  • Posts: 22
Re: Problems Installing a Package.
« Reply #2 on: September 14, 2019, 06:56:27 pm »
I did that, and I still get the same error. I'll try installing  Lazarus 2.0.4, and see if I have better luck. by the way I am using win 7.
« Last Edit: September 14, 2019, 07:06:19 pm by sergioantonio2013 »

sergioantonio2013

  • New Member
  • *
  • Posts: 22
Re: Problems Installing a Package.
« Reply #3 on: September 14, 2019, 07:38:22 pm »
The problem went away when I upgraded to 2.0.4.