Recent

Author Topic: Weird editor behavior using arrows ...  (Read 212 times)

andresayang

  • Jr. Member
  • **
  • Posts: 59
Weird editor behavior using arrows ...
« on: September 12, 2019, 04:34:34 pm »
Hi All,

I hope the topic does not already exist otherwise, sorry !
In editor, using arrows, when I lease arrow pressed to use the keyboard repeat function, editor switch automatically on other opened page (units).

It this a feature or a bug ?

Or maybe coming from my particular setup ?

I'm using Lazarus (latests version) on Debian 9, but I'm using Synergy between several computers (3 sharing same Keyboard / mouse).

Thanks
Linux, Debian 9
Lazarus: always latest release

winni

  • Full Member
  • ***
  • Posts: 192
Re: Weird editor behavior using arrows ...
« Reply #1 on: September 12, 2019, 06:12:03 pm »
Hi!

Yes, you are allowed to configure some "keyboard nonsense" in the IDE.

The way to the shortkey for jumping to the next editor windows: (translated back from german):

Tools --> Preferences --> Editor --> Keyboard --> Editor Commands --> Jump to next editor window

For me it is Ctrl Tab. I think that  is the default. Do you have perhaps here some cursor (arrow) keys? Then change it.

Winni

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 5575
    • wiki
Re: Weird editor behavior using arrows ...
« Reply #2 on: September 12, 2019, 08:06:06 pm »
If you refer to the normal "cursor Up/Down/Left/Right" keys...  Then this should not happen.

It is possible in the option to change what they do. But then it would happen on first key-press.

SO IF:
- On first key press: all is ok
- On keep key down: it changes the editor-tab

That is not expected.

After that happens, can you type in the new tab? Or is the focus suddenly gone? Maybe the "tabs" themself got focused?

I have no idea how this can happen.
What desktop/windowmanager are you using? Maybe someone knows if there is a problem with a specific one...

-----------------------
Most important: You say Debian => That is your primary OS ?

- You are NOT running in a virtual machine?
- And you are not running via remote access? (your keyboard is actually connected to the computer running Debian?)



lucamar

  • Hero Member
  • *****
  • Posts: 1991
Re: Weird editor behavior using arrows ...
« Reply #3 on: September 12, 2019, 09:03:59 pm »
I don't know whether this will be useful but things like that happen from time to time to me (on several versions/flavours of Ubuntu) and normally they are due to either an accidental press on a shift key or/and a "not too clean" keyboard, and if you're using a laptop or a small combo-keyboard this kind of problems are exacerbated by the proximity of the touchpad.

The solutions are obvious: clean the keyboard(-s) regularly and try to type only with the fingers ;)
« Last Edit: September 12, 2019, 09:17:26 pm by lucamar »
Turbo Pascal 3 CP/M - Amstrad PCW 8256 (512 KB !!!) :P
Lazarus 2.0.2/2.0.4  - FPC 3.0.4 on:
(K|L)Ubuntu 12..16, Windows XP SP3, various DOSes.

andresayang

  • Jr. Member
  • **
  • Posts: 59
Re: Weird editor behavior using arrows ...
« Reply #4 on: September 12, 2019, 10:58:13 pm »
Hi!
Yes, you are allowed to configure some "keyboard nonsense" in the IDE.
The way to the shortkey for jumping to the next editor windows: (translated back from german):
Tools --> Preferences --> Editor --> Keyboard --> Editor Commands --> Jump to next editor window
For me it is Ctrl Tab. I think that  is the default. Do you have perhaps here some cursor (arrow) keys? Then change it.
Winni

Well, I just install 2.0.4 on my laptop, and remove all previous files, so no, not coming from this

I don't know whether this will be useful but things like that happen from time to time to me (on several versions/flavours of Ubuntu) and normally they are due to either an accidental press on a shift key or/and a "not too clean" keyboard, and if you're using a laptop or a small combo-keyboard this kind of problems are exacerbated by the proximity of the touchpad.
The solutions are obvious: clean the keyboard(-s) regularly and try to type only with the fingers ;)
Keyborad is brend new (2-3 month usage), so do not think so.

If you refer to the normal "cursor Up/Down/Left/Right" keys...  Then this should not happen.
It is possible in the option to change what they do. But then it would happen on first key-press.
SO IF:
- On first key press: all is ok
- On keep key down: it changes the editor-tab
That is not expected.
After that happens, can you type in the new tab? Or is the focus suddenly gone? Maybe the "tabs" themself got focused?
I have no idea how this can happen.
What desktop/windowmanager are you using? Maybe someone knows if there is a problem with a specific one...
-----------------------
Most important: You say Debian => That is your primary OS ?
- You are NOT running in a virtual machine?
- And you are not running via remote access? (your keyboard is actually connected to the computer running Debian?)

"If you refer to the normal "cursor Up/Down/Left/Right" keys... " :Yes, those key.
"- On first key press: all is ok - On keep key down: it changes the editor-tab": It is not always, it is almost unpredictable. But it is what happen.
After that happens, can you type in the new tab? Or is the focus suddenly gone? Maybe the "tabs" themself got focused?: Yes I can edit the new tab, maybe the tab get focused somehow, I'll try to check this.

I'm working on Debian 9 (All updated), with Gnome, not any virtual machine. Working on local. Mainly with Synergy, but when I work on my laptop alone (no synergy or whatever, it also happen)

I also notice that with Up/Down key, the cursor disappear, maybe exactly the same thing, cursor disappear with Up/Down, and right/left make switch tab.

Is there any way to log what happen and give you feedback ?

Cheers
« Last Edit: September 12, 2019, 11:01:10 pm by andresayang »
Linux, Debian 9
Lazarus: always latest release