Recent

Author Topic: Unable to install lazopenglcontext from command line  (Read 228 times)

ChrisR

  • Full Member
  • ***
  • Posts: 103
Unable to install lazopenglcontext from command line
« on: September 12, 2019, 03:19:55 pm »
Hello-

This might be a duplicate of
  https://forum.lazarus.freepascal.org/index.php/topic,31585.0.html
but if so the issue still persists 3 years later in Lazarus2.0.0 (default Debian install).

I am trying to build my code using Docker. The code below emulates everything. Everything works fine up to "lazbuild --add-package lazopenglcontext --build-ide=" - indeed I can even install the external "python4lazarus" to the ide. However when I run:

"lazbuild --add-package lazopenglcontext --build-ide=

I get the error

Note: (lazarus) renamed file "/usr/lib/lazarus/2.0.0/lazarus" to "/usr/lib/lazarus/2.0.0/lazarus.old"
Hint: (lazarus) [RunTool] /usr/bin/make "-iWTOTP" "-Fr/usr/lib/lazarus/2.0.0/components/codetools/fpc.errore.msg" "-Fr/usr/lib/lazarus/2.0.0/components/codetools/fpc.errore.msg"
Hint: (lazarus) [RunTool] /usr/bin/make "-va" "-Fr/usr/lib/lazarus/2.0.0/components/codetools/fpc.errore.msg" "-Fr/usr/lib/lazarus/2.0.0/components/codetools/fpc.errore.msg" "compilertest.pas"
....
make[2]: *** [Makefile:3972: lazarus] Error 1
make[1]: *** [Makefile:4394: idepkg] Error 2
make: *** [Makefile:3171: idepkg] Error 2
/root/.lazarus/staticpackages.inc(1,1) Fatal: (10022) Can't find unit lazopenglcontext used by Lazarus
Fatal: (1018) Compilation aborted
Error: /usr/bin/ppcx64 returned an error exitcode
make[2]: Leaving directory '/usr/lib/lazarus/2.0.0/ide'
make[1]: Leaving directory '/usr/lib/lazarus/2.0.0/ide'
make: Leaving directory '/usr/lib/lazarus/2.0.0'
Error: (lazarus) Build IDE: stopped with exit code 2
Error: (lazarus) Building IDE: Building IDE failed.



I get the same error when I run
  lazbuild --add-package /usr/lib/lazarus/default/components/opengl/lazopenglcontext.lpk  --build-ide=
even though
  > ls /usr/lib/lazarus/default/components/opengl/
reports the "missing" file is present in this folder:
  openglcontext.pas


--------------


docker pull jgoerzen/debian-base-standard
docker run -td --stop-signal=SIGPWR --name=name jgoerzen/debian-base-standard
docker run -it jgoerzen/debian-base-standard /bin/bash



apt-get update
apt-get -yq install lazarus
apt-get -yq install git
apt-get -yq install libgl1-mesa-dev
cd ~
git clone https://github.com/rordenlab/MRIcroGL12.git
git clone https://github.com/neurolabusc/Metal-Demos
git clone https://github.com/Alexey-T/Python-for-Lazarus.git
lazbuild --add-package ~/Python-for-Lazarus/python4lazarus/python4lazarus_package.lpk  --build-ide=
lazbuild --add-package lazopenglcontext --build-ide=
#lazbuild --add-package /usr/lib/lazarus/default/components/opengl/lazopenglcontext.lpk  --build-ide=
# lazbuild --lazarusdir="/usr/lib/lazarus/default" --add-package lazopenglcontext --build-ide=
cd MRIcroGL12
lazbuild -B --lazarusdir="/usr/lib/lazarus/default" ./MRIcroGL.lpr

ChrisR

  • Full Member
  • ***
  • Posts: 103
Re: Unable to install lazopenglcontext from command line
« Reply #1 on: September 12, 2019, 09:44:56 pm »
For Debian 10 (Buster) the default Lazarus install is 2.0.0. My solution to this problem was to download and install Lazarus 2.0.4 from SourceForge:

docker pull jgoerzen/debian-base-standard
docker run -td --stop-signal=SIGPWR --name=name jgoerzen/debian-base-standard

docker run -it jgoerzen/debian-base-standard /bin/bash
cd ~
wget --no-check-certificate https://sourceforge.net/projects/lazarus/files/Lazarus%20Linux%20amd64%20DEB/Lazarus%202.0.4/lazarus-project_2.0.4-0_amd64.deb
wget --no-check-certificate https://sourceforge.net/projects/lazarus/files/Lazarus%20Linux%20amd64%20DEB/Lazarus%202.0.4/fpc-src_3.0.4-2_amd64.deb
wget --no-check-certificate https://sourceforge.net/projects/lazarus/files/Lazarus%20Linux%20amd64%20DEB/Lazarus%202.0.4/fpc-laz_3.0.4-1_amd64.deb
apt-get update
apt -yq install ./fpc-src_3.0.4-2_amd64.deb
apt -yq install ./fpc-laz_3.0.4-1_amd64.deb
apt -yq install ./lazarus-project_2.0.4-0_amd64.deb
apt-get -yq install git
apt-get -yq install libgl1-mesa-dev
apt-get install build-essential
git clone https://github.com/rordenlab/MRIcroGL12.git
git clone https://github.com/neurolabusc/Metal-Demos
git clone https://github.com/Alexey-T/Python-for-Lazarus.git
lazbuild --add-package ~/Python-for-Lazarus/python4lazarus/python4lazarus_package.lpk  --build-ide=
lazbuild --add-package lazopenglcontext --build-ide=
cd MRIcroGL12
lazbuild -B ./MRIcroGL.lpr