Recent

Author Topic: cant find fpdebug - new install debian10  (Read 878 times)

Michael Collier

  • Sr. Member
  • ****
  • Posts: 253
cant find fpdebug - new install debian10
« on: September 02, 2019, 12:20:10 pm »
I'm testing installation of lazarus on debian10 and when I rebuild IDE I get "cant find fpdebug"

Steps:

1. Install debian10
2. apt-get update
3. apt-get upgrade
4. synaptic package manager install gdb
5. synaptic package manager install lazarus
6. Open lazarus, do anything to rebuild IDE, (I tried adding indy10 and rebuilding).

Any ideas? maybe use a different install method for lazarus? can this error be fixed with current installation? I'm happy to keep re-installing, the machine is dedicated to installing debian/lazarus.

Thanks

rvk

  • Hero Member
  • *****
  • Posts: 3842
Re: cant find fpdebug - new install debian10
« Reply #1 on: September 02, 2019, 12:27:15 pm »
What debugger is selected under Toos > Options > Debugger.
It should be the GDB debugger.
If it is fpdebug, try changing it to GDB.

Michael Collier

  • Sr. Member
  • ****
  • Posts: 253
Re: cant find fpdebug - new install debian10
« Reply #2 on: September 02, 2019, 12:41:11 pm »
Thanks, checked, was/is gdb, still error

Michael Collier

  • Sr. Member
  • ****
  • Posts: 253
Re: cant find fpdebug - new install debian10
« Reply #3 on: September 02, 2019, 12:44:24 pm »
I opened fpdebug package and compiled it.

When I try to rebuild IDE it says it cant find virtual_treeview , so again opened virtual_tree_view package and compiled it.

When I try to rebuild IDE I get can't find OLE (something)..

Error messages are from memory so may contain typos..

Does this help?

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 5699
    • wiki
Re: cant find fpdebug - new install debian10
« Reply #4 on: September 02, 2019, 12:45:36 pm »
I do not know which exact version "apt" does get you. Nor if it is complete.

FpDebug has been around for a long time.
Since Lazarus 1.2 it is in components/fpdebug and there should be an fdpdebug.lpk and pas, and many other files.

So check the source folder. If it is not there, then the install is incomplete.


If it is there, from the "package" menu, do "open package" and select the lpk.

Lazarus has a memory where a package was last seen. If that is pointing to the wrong place you get an error. Opening a package will update this info.


Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 5699
    • wiki
Re: cant find fpdebug - new install debian10
« Reply #5 on: September 02, 2019, 12:48:54 pm »
last reply overlapped.

Looks like your installation directory changed.

In tools options, make sure your lazarus directory is correct


I am not sure where the old locations are saved.

Probably in ~/.lazarus

Also in your source dir, under the directory packager, there is (in a further subdir) a bunch of *.lpl files. Open one of them for a package that fail, *before* you open the package by hand. It should have the correct path to the package. If not its broken

Munair

  • Sr. Member
  • ****
  • Posts: 473
  • Try to KISS (keep it simple, smart)
    • Ditrianum
Re: cant find fpdebug - new install debian10
« Reply #6 on: September 02, 2019, 01:32:21 pm »
I get better results when installing the latest Lazarus (three packages) (https://www.lazarus-ide.org/index.php?page=downloads)
Lazarus 2.0.4; Manjaro, Debian, Windows

rvk

  • Hero Member
  • *****
  • Posts: 3842
Re: cant find fpdebug - new install debian10
« Reply #7 on: September 02, 2019, 01:34:59 pm »
I can confirm. Newly installed Debian 10 (default install, nothing else selected so no synaptic)

Quote
su root
apt-get install update
apt-get install upgrade
apt-get install gdb
apt-get install lazarus
exit
startlazarus

Choosing Tools > Build Lazarus with Profile: Normal IDE
results in
Quote
Build IDE: Exit code 2, Errors: 1, Warnings: 18, Hints: 24
fppkghelper.pas(28,31) Hint: Parameter "PackageName" not used
fppkghelper.pas(29,28) Hint: Parameter "AList" not used
fppkghelper.pas(13,3) Hint: Unit "fprepos" not used in FppkgHelper
packagesystem.pas(4295,3) Note: Local variable "FPCParser" is assigned but never used
packagesystem.pas(4298,3) Note: Local variable "ExtToolData" not used
packagesystem.pas(408,40) Hint: Parameter "ShowAbort" not used
sourcesyneditor.pas(1574,35) Warning: Symbol "FScreenCaretPainterClass" is deprecated: "need refactor"
sourcesyneditor.pas(1581,35) Warning: Symbol "FScreenCaretPainterClass" is deprecated: "need refactor"
mainintf.pas(73,42) Hint: Unit "PublishModule" not used in MainIntf
addtopackagedlg.pas(85,5) Warning: Constructor should be public
addtopackagedlg.pas(33,3) Hint: Unit "math" not used in AddToPackageDlg
addtopackagedlg.pas(43,38) Hint: Unit "IDEDefs" not used in AddToPackageDlg
addtopackagedlg.pas(44,31) Hint: Unit "ProjPackChecks" not used in AddToPackageDlg
addfpmakedependencydlg.pas(37,37) Hint: Parameter "AProjPack" not used
addfpmakedependencydlg.pas(9,19) Hint: Unit "fgl" not used in AddFPMakeDependencyDlg
watchesdlg.pp(125,58) Hint: Parameter "X" not used
watchesdlg.pp(125,61) Hint: Parameter "Y" not used
watchesdlg.pp(126,58) Hint: Parameter "X" not used
watchesdlg.pp(126,61) Hint: Parameter "Y" not used
watchesdlg.pp(127,7) Hint: Parameter "State" not used
pseudoterminaldlg.pp(132,16) Warning: Symbol "PseudoTerminal" is experimental
pseudoterminaldlg.pp(179,16) Warning: Symbol "PseudoTerminal" is experimental
pseudoterminaldlg.pp(274,18) Warning: Symbol "PseudoTerminal" is experimental
pseudoterminaldlg.pp(282,30) Warning: Symbol "PseudoTerminal" is experimental
pseudoterminaldlg.pp(500,5) Hint: Local const "bsW" is not used
pseudoterminaldlg.pp(508,5) Hint: Local const "crB" is not used
pseudoterminaldlg.pp(526,5) Hint: Local const "gsB" is not used
pseudoterminaldlg.pp(529,5) Hint: Local const "rsB" is not used
pseudoterminaldlg.pp(532,5) Hint: Local const "usB" is not used
pseudoterminaldlg.pp(664,19) Warning: Implicit string type conversion from "AnsiString" to "WideString"
pseudoterminaldlg.pp(667,72) Warning: Implicit string type conversion from "ShortString" to "UnicodeString"
pseudoterminaldlg.pp(675,13) Warning: Implicit string type conversion from "Char" to "UnicodeString"
pseudoterminaldlg.pp(684,7) Warning: Implicit string type conversion with potential data loss from "WideString" to "AnsiString"
pseudoterminaldlg.pp(685,93) Warning: Implicit string type conversion with potential data loss from "WideString" to "AnsiString"
pseudoterminaldlg.pp(760,41) Warning: Implicit string type conversion with potential data loss from "WideString" to "AnsiString"
pseudoterminaldlg.pp(762,83) Warning: Implicit string type conversion with potential data loss from "WideString" to "AnsiString"
pseudoterminaldlg.pp(765,5) Warning: Implicit string type conversion with potential data loss from "WideString" to "AnsiString"
debugmanager.pas(2488,15) Warning: Symbol "OnDbgEvent" is deprecated: "swich to EventLogHandler"
debugmanager.pas(3105,25) Warning: Symbol "PseudoTerminal" is experimental
debugmanager.pas(3178,15) Warning: Symbol "OnDbgEvent" is deprecated: "swich to EventLogHandler"
editor_keymapping_options.pas(96,13) Hint: Parameter "aShortCut" not used
project_application_options.pas(13,22) Hint: Unit "LCLStrConsts" not used in project_application_options
lazarus.pp(1,1) Fatal: Cannot find fpdebug used by Lazarus.

Munair

  • Sr. Member
  • ****
  • Posts: 473
  • Try to KISS (keep it simple, smart)
    • Ditrianum
Re: cant find fpdebug - new install debian10
« Reply #8 on: September 02, 2019, 02:03:27 pm »
I can confirm. Newly installed Debian 10 (default install, nothing else selected so no synaptic)

Quote
su root
apt-get install update
apt-get install upgrade
apt-get install gdb
apt-get install lazarus
exit
startlazarus

I wouldn't install as root. Better give your user account super user status and install with sudo.

Debian 10 has Lazarus 2.0.0 in its repository with fpc 3.0.4. I did not install any of them. I downloaded Lazarus 2.0.2 (on Debian 9) and Lazarus 2.0.4 on Debian 10 with fpc-laz 3.0.4 and fpc-source 3.0.4. The forum may give better support if you use these latest versions.
Lazarus 2.0.4; Manjaro, Debian, Windows

rvk

  • Hero Member
  • *****
  • Posts: 3842
Re: cant find fpdebug - new install debian10
« Reply #9 on: September 02, 2019, 02:14:16 pm »
I wouldn't install as root. Better give your user account super user status and install with sudo.
I actually did. I did this under sudo -i
But in that case it is still installed as root (seeing the directories created).

Quote
Debian 10 has Lazarus 2.0.0 in its repository with fpc 3.0.4. I did not install any of them. I downloaded Lazarus 2.0.2 (on Debian 9) and Lazarus 2.0.4 on Debian 10 with fpc-laz 3.0.4 and fpc-source 3.0.4. The forum may give better support if you use these latest versions.
Yeah, that's why I still hate those packages.

My preferred method is installing trunk with my own script into my own userspace ~/dev. (/home/pi/dev on the rpi and /home/rik/dev on pc)
Recompiling Lazarus will install lot's of stuff in ~ anyway because it can't recompile itself in the correct position without root.
Quote
int: (lazarus) [CalcTargets] Lazarus directory is readonly, using fallback target directory: /home/rik/.lazarus/bin

But it seems that the standard Debian package is broken (when it comes to rebuilding Lazarus itself).

Michael Collier

  • Sr. Member
  • ****
  • Posts: 253
Re: cant find fpdebug - new install debian10
« Reply #10 on: September 02, 2019, 02:40:44 pm »
Thanks for help,

for anyone reading this in future..

installed debian10
I added my_username  to sudo (note the hyphen after sudo or adduser will not be found)
su -
adduser my_username sudo
(I logged out and logged in again as my_username  just in case)

installed gtk2.0.
sudo apt-get install gtk2.0.

downloaded 3 files from https://www.lazarus-ide.org/index.php?page=downloads
installed each file using:
sudo dpkg -i <path to deb file downloaded>

..edit: forgot to mention gdb
sudo apt-get install gdb

So far seems ok.. can install packages / rebuild IDE

Thanks again,
Mike
« Last Edit: September 02, 2019, 02:52:41 pm by Michael Collier »

Munair

  • Sr. Member
  • ****
  • Posts: 473
  • Try to KISS (keep it simple, smart)
    • Ditrianum
Re: cant find fpdebug - new install debian10
« Reply #11 on: September 02, 2019, 05:02:23 pm »
Hmm, was installation of gtk2.0 required for Lazarus to be able to recompile?
Lazarus 2.0.4; Manjaro, Debian, Windows

rvk

  • Hero Member
  • *****
  • Posts: 3842
Re: cant find fpdebug - new install debian10
« Reply #12 on: September 02, 2019, 05:08:41 pm »
Hmm, was installation of gtk2.0 required for Lazarus to be able to recompile?
I don't think so.
But Michael also reinstalled Lazarus from the .deb files from lazarus-ide.org itself.
That's probably the reason why it now works.


Michael Collier

  • Sr. Member
  • ****
  • Posts: 253
Re: cant find fpdebug - new install debian10
« Reply #13 on: September 02, 2019, 05:22:30 pm »
Hi, from memory ( I've restarted the debian machine so don't have old outputs), I needed gtk2.0. in order to install the .deb files. I believe it gave a dependency error. I only mentioned it in this thread so users are able to do a successful Lazarus install on debian10. I'm pretty sure gtk2.0. is not part of the original problem of recompiling Lazarus.


Munair

  • Sr. Member
  • ****
  • Posts: 473
  • Try to KISS (keep it simple, smart)
    • Ditrianum
Re: cant find fpdebug - new install debian10
« Reply #14 on: September 02, 2019, 06:13:52 pm »
Just to let you know, I recently installed Debian 10, downloaded the latest Lazarus installation files from lazarus-ide.org (deb packages) and found no unusual dependency problems. However, there can be a conflict if you installed the fpc version from the repo. I found that Lazarus requires fpc-laz that comes with the latest version (as separate packages), which means that any fpc package from the repo should not be installed. Other than that I found no issues with gtk. I expect the latest Lazarus to also install without issues on Debian 9 either with Gtk or Qt based desktop.

What you may be referring to as gtk 2.0 though are the dev (development) files, but there's a whole bunch of dev files (not just gtk) that will be installed as dependencies of the Lazarus package (not fpc).
Lazarus 2.0.4; Manjaro, Debian, Windows