Recent

Author Topic: Lazarus 1.7 -- Close CodeExplorer window in IDE  (Read 753 times)

Curt Carpenter

  • Full Member
  • ***
  • Posts: 129
Lazarus 1.7 -- Close CodeExplorer window in IDE
« on: August 17, 2019, 11:35:30 pm »
I can't see how to close the CodeExplorer area and remove it from my IDE.  What's the secret?

lucamar

  • Hero Member
  • *****
  • Posts: 3017
Re: Lazarus 1.7 -- Close CodeExplorer window in IDE
« Reply #1 on: August 18, 2019, 02:26:45 am »
Have you tried clicking on the "Close window" button (in the title bar) or just plain old Alt+F4?
Turbo Pascal 3 CP/M - Amstrad PCW 8256 (512 KB !!!) :P
Lazarus 2.0.8/FPC 3.0.4 - 32/64 bits on:
(K|L|X)Ubuntu 12..18, Windows XP, 7, 10 and various DOSes.

Curt Carpenter

  • Full Member
  • ***
  • Posts: 129
Re: Lazarus 1.7 -- Close CodeExplorer window in IDE
« Reply #2 on: August 18, 2019, 07:27:58 pm »
Thanks, but I'm darned if I can find a Close window button specific to the CodeExplorer (it has no title bar that I can find either).  And Alt+F4 closes the whole IDE for me, not just the Code Explorer. 

I'm thinking that maybe it just can't be removed, only resized to become invisible within the IDE window. 

Thaddy

  • Hero Member
  • *****
  • Posts: 10436
Re: Lazarus 1.7 -- Close CodeExplorer window in IDE
« Reply #3 on: August 18, 2019, 07:29:50 pm »
1.7 is rather old. Upgrade first.
When you ask a question that is actually answered in the documentation, you are either lazy or a moron.

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 6592
    • wiki
Re: Lazarus 1.7 -- Close CodeExplorer window in IDE
« Reply #4 on: August 18, 2019, 07:44:52 pm »
Thanks, but I'm darned if I can find a Close window button specific to the CodeExplorer (it has no title bar that I can find either).  And Alt+F4 closes the whole IDE for me, not just the Code Explorer. 

I'm thinking that maybe it just can't be removed, only resized to become invisible within the IDE window.
Are you running AnchorDocking or something like that? You should mention if you do.

If so, then maybe you locked or hidden the window headers?
Tools > Options > Environment > Docking: Show Headers.

Or if you have tabbed docking, right click the tabs  (not the source editor tabs, only tabs related to docking)

 

TinyPortal © 2005-2018