Recent

Author Topic: (Solved) Compiling Lazarus IDE 2 on Raspberry Pi  (Read 288 times)

jdp

  • Jr. Member
  • **
  • Posts: 76
(Solved) Compiling Lazarus IDE 2 on Raspberry Pi
« on: July 29, 2019, 09:32:45 pm »
Hi all.

I have been using Lazarus on the Pi for about 4 years now and all works 100%.
I now got a new Pi 4 with the Buster OS. I did a apt-get install lazarus and it installed version 2

I need to add some visual componants to the IDE. If I add them from the online package manager and do a rebuild I get this error.

Code: Pascal  [Select]
  1. lazarus.pp(1,1) Fatal: Cannot find fpdebug used by Lazarus. Check if package fpdebug creates fpdebug.ppu, check nothing deletes this file and check that no two packages have access to the unit source..

What could be the issue now ?

Regards.
« Last Edit: August 01, 2019, 09:16:23 am by jdp »

pik33

  • Jr. Member
  • **
  • Posts: 63
Re: Compiling Lazarus IDE 2 on Raspberry Pi
« Reply #1 on: July 30, 2019, 08:52:16 am »
I have the same error. Also, the Intel based PC with Debian 10 /Buster does the same thing

jdp

  • Jr. Member
  • **
  • Posts: 76
Re: Compiling Lazarus IDE 2 on Raspberry Pi
« Reply #2 on: July 30, 2019, 09:22:08 pm »
Aaaa this is sooo frustrating.

I bought the book "LazarusHandbook" and followed all the steps to the letter. I got version 2.0.2 installed.

Now if I add packages I get the error

Code: Pascal  [Select]
  1. lazarus.pp(167,1) Error: Can't call the resource compiler "/usr/local/bin/fpcres", switching to external mode


Please help me.......

jdp

  • Jr. Member
  • **
  • Posts: 76
Re: Compiling Lazarus IDE 2 on Raspberry Pi
« Reply #3 on: July 30, 2019, 09:55:11 pm »
OK so I had to make the swap file 1024 MB. It seems the compiler ran out of memory.

Now When I want to install packages from the on-line package manager and now I get errors that the version of FPC is not supported.

Aaaa I want to cry .......