Recent

Author Topic: [SOLVED] Interfaces.ppu error  (Read 458 times)

Chris54000

  • New member
  • *
  • Posts: 8
[SOLVED] Interfaces.ppu error
« on: July 16, 2019, 10:16:46 pm »
Good evening,

Firstly sorry for my english, i'm french.
I have a problem with Lazarus.
When I try to compile EDI, I have a message that says Interfaces.ppu is incompatible.
I have the latest version of Lazarus(2.0.2) with Windows 10.
Thank you in advance if you have the solution.
« Last Edit: July 19, 2019, 09:48:31 pm by Chris54000 »

Bart

  • Hero Member
  • *****
  • Posts: 3465
    • Bart en Mariska's Webstek
Re: Interfaces.ppu error
« Reply #1 on: July 16, 2019, 11:13:34 pm »
You can try:
Remove all lesftovers from a previous installed Lazarus.
Do a clean build.

Bart

Chris54000

  • New member
  • *
  • Posts: 8
Re: Interfaces.ppu error
« Reply #2 on: July 17, 2019, 09:28:09 pm »
Good evening,

It's a first instalaltion but yes i tried all options.

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 5525
    • wiki
Re: Interfaces.ppu error
« Reply #3 on: July 17, 2019, 09:40:49 pm »
Please try:

- Menu: Tools > "Configure build Lazarus"
- Find the radio-button: "Clean all" and check it.
- Press button "Build"

If that does not help, search for every file called "interfaces.ppu" in your lazarus directory. Delete all of them.
Repeat "Build"

Chris54000

  • New member
  • *
  • Posts: 8
Re: Interfaces.ppu error
« Reply #4 on: July 17, 2019, 09:48:24 pm »
Thank you for your answer.
I tried but I still have the same message.

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 5525
    • wiki
Re: Interfaces.ppu error
« Reply #5 on: July 17, 2019, 10:14:54 pm »
When you get the error, please right click the messages window, and in the context-menu choose: Copy > All and original messages
Paste or attach this here.


Just to be sure:
This is your first and only Lazarus install?
You did not have any Lazarus in the past?
You did not have any FPC in the past (or now)?
You did not have CodeTyphon in the past (or now)?

Did you try to install any packages from other sources? Online Package Manager, or downloaded from 3rd party?

Chris54000

  • New member
  • *
  • Posts: 8
Re: Interfaces.ppu error
« Reply #6 on: July 17, 2019, 11:15:58 pm »
I have installed and uninstalled several times because of this problem.
The only IDE that is still installed is CodeBlock

Chris54000

  • New member
  • *
  • Posts: 8
Re: Interfaces.ppu error
« Reply #7 on: July 17, 2019, 11:16:38 pm »
Second parts:

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 5525
    • wiki
Re: Interfaces.ppu error
« Reply #8 on: July 17, 2019, 11:40:07 pm »
OK, it looks like the error is misleading. The interfaces.ppu is probably all right.

Something puts a single unmatched ' (single quote) into one of the commandlines that get executed. That prevents the compiler from functioning.

I can think of 2 possibilities.

1) Tools > Configure build lazarus
In the big edit/memo called "Options", did you by any chance accidentally put that ' in there?

2) "make.exe"
This may be an interaction with something else installed on your PC. Most likely CodeBlocks.

Lazarus use make.exe, and depends on the correct flavour/version of that.
If your global environment "PATH" contains any location with an alternative make.exe, then this wrong make.exe can get picked up.  This might cause the issue at hand.

To test (not 100% sure about the steps), open cmd.exe
set PATH=''
cd c:\lazarus\
lazarus.exe

Chris54000

  • New member
  • *
  • Posts: 8
Re: Interfaces.ppu error
« Reply #9 on: July 18, 2019, 09:52:17 pm »
Good evening,

I desinstalled Codeblocks and I tried your command but I still have this mistake

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 5525
    • wiki
Re: Interfaces.ppu error
« Reply #10 on: July 18, 2019, 10:43:13 pm »
I think I got it. At least I can get the same error.

It appears your username ends in a '
And that upsets the IDE or make.exe

- Make sure your lazarus is installed into a folder that has only A-Z 0-9 _ in it. e.g. C:\lazarus  (the drive does not matter. D: is fine too)
  At least no '  spaces may work (or not)

- Create a folder C:\laz_conf  or c:\lazarus\conf  (or if you have and want any other drive D:\laz)
- In the lazarus install directory create a text file
   lazarus.cfg
  and put the single line  (no spaces at start or end) / adjust the path to what you created
   --primary-config-path=C:\laz_conf   

That way the quote from your username would not appear in any path, that the IDE accesses.

Start lazarus. In the menu View > IDE internals > About IDE  it should print the primary config path. Make sure it is the new one.

Then it should work.

---
You can use the installer to get you all of the above done. Check "secondary Installation", then it will ask for the config path. The config path can be inside the install directory ( a subfolder), but is not allowed to be the same path as the install dir.
« Last Edit: July 18, 2019, 10:45:43 pm by Martin_fr »

Chris54000

  • New member
  • *
  • Posts: 8
Re: Interfaces.ppu error
« Reply #11 on: July 18, 2019, 11:37:58 pm »
I did not succeed with the cfg file so I created a new admin account with my full name and installed Lazarus.
I tried to compile the EDI and it worked.
Thank you very much for finding the error, I will see for this file cfg.

Chris54000

  • New member
  • *
  • Posts: 8
Re: Interfaces.ppu error
« Reply #12 on: July 18, 2019, 11:47:59 pm »
I didn’t see your addition.
I uninstalled Lazarus and I did a secondary installation and it works.
I deleted the second account.
Thank you so much for your help   ;)

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 5525
    • wiki
Re: Interfaces.ppu error
« Reply #13 on: July 19, 2019, 01:25:26 am »
Glad that it works :)