Recent

Author Topic: UTF8 symbols in Editor - strange copy & paste  (Read 1258 times)

winni

  • Sr. Member
  • ****
  • Posts: 340
Re: UTF8 symbols in Editor - strange copy & paste
« Reply #15 on: July 06, 2019, 02:02:05 am »
@Martin_fr

I have added your "magic" line into synedittextbuffer.pp line 902 (not: 920) and compiled everything. But that did not help: same symptoms as before: the zodiak is show as emojis, not as signs.

I still think the KDE clipboard is buggy.

But a lot of thanx anyway

engkin

  • Hero Member
  • *****
  • Posts: 2513
Re: UTF8 symbols in Editor - strange copy & paste
« Reply #16 on: July 06, 2019, 02:18:09 am »
You tried it with the variation marker U+FE0E?

Edit:
It would help to show the code you used.
« Last Edit: July 06, 2019, 02:20:13 am by engkin »

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 5638
    • wiki
Re: UTF8 symbols in Editor - strange copy & paste
« Reply #17 on: July 06, 2019, 02:50:33 am »
A bit of googling. Looks like it is a Pango feature. Afaik the LCL-gtk uses pango...

There are some references that it can be controlled by editing fontconfig, but I did not test. Also that sounds like a system wide change. Not per APP.

Also if it is pango, then there might be an API call to switch it off (but the LCL would not have that). Or maybe some other apps use alternatives to pango?

winni

  • Sr. Member
  • ****
  • Posts: 340
Re: UTF8 symbols in Editor - strange copy & paste
« Reply #18 on: July 06, 2019, 10:05:35 pm »
Concerning KDE: They hat a problem with disabeling Emojis in Kmail. Nothing else with a quick view found.

And now to fontconfig: We are not the only one, who are bothered.  The chaos in detail, have a look a this project: https://github.com/stove-panini/fontconfig-emoji

He is realy bugged.

Btw: WordPress now has a module to disable Emojis. Would be nice for Lazarus!


Winni