Recent

Author Topic: Raspberry Pi, Raspian Buster with Lazarus 2.0.0 and FPC 3.04  (Read 1141 times)

han

  • Jr. Member
  • **
  • Posts: 58
FYI, after you install the brand new new operating system Raspian Buster on Pi3 or Pi4, you can install Lazarus 2.0.0 and FPC 3.0.4 simply by the following:

sudo apt-get install lazarus

This makes it much much simpler.  :D
« Last Edit: June 26, 2019, 05:35:51 pm by han »

rvk

  • Hero Member
  • *****
  • Posts: 3803
Re: Raspberry Pi, Raspian Buster with Lazarus 2.0.0 and FPC 3.04
« Reply #1 on: June 26, 2019, 06:30:14 pm »
you can install Lazarus 2.0.0 and FPC 3.0.4...
Mmmmh, which isn't the latest release (2.0.2 as of 16-04-2019).

Thaddy

  • Hero Member
  • *****
  • Posts: 8673
Re: Raspberry Pi, Raspian Buster with Lazarus 2.0.0 and FPC 3.04
« Reply #2 on: June 26, 2019, 07:03:18 pm »
Raspbian Buster is afaik not complete (and Debian buster is released later this week) and not every package is ported yet. I can only test it after my RPI 4 deliveries.
It  *should* contain fpc 3.0.4 and Lazarus 2.0.0, because that is in stretch - backports.
What I DO know, is that you can copy your old installation and that should work, provided all dependencies are satisfied.
.You are just a bit too soon.....be patient.

https://wiki.debian.org/DebianBuster

Don't even tell buster will be released this week: There is no announcement yet. Except for RaspBian (under the same restrictions...)

For now I'd recommend to keep Stretch, unless you already have a RPi 4, (needs Buster!),, which I ordered but do not have
« Last Edit: June 26, 2019, 07:07:50 pm by Thaddy »
Most people that want to use threading should learn to patch their jeans first: use a needle.

rvk

  • Hero Member
  • *****
  • Posts: 3803
Re: Raspberry Pi, Raspian Buster with Lazarus 2.0.0 and FPC 3.04
« Reply #3 on: June 26, 2019, 07:28:26 pm »
For an intel-server I already switched to buster last week. I needed php7.3 and was caught in a dependency hell, so I upgraded everything. For now it's working fine (for mail and webserver, no gui stuff).

As far as I know buster was freezed some time ago so what's in 'testing' now should be final (but you never know).

Thaddy

  • Hero Member
  • *****
  • Posts: 8673
Re: Raspberry Pi, Raspian Buster with Lazarus 2.0.0 and FPC 3.04
« Reply #4 on: June 26, 2019, 07:32:14 pm »
Yes, Rik, It is frozen, pending release ... (Just like fpc 3.2.0..... :o :o :o)
In both cases there are still bug-fixes applied, but functionality is frozen indeed.
« Last Edit: June 26, 2019, 07:33:46 pm by Thaddy »
Most people that want to use threading should learn to patch their jeans first: use a needle.

Brizeux

  • New Member
  • *
  • Posts: 11
Re: Raspberry Pi, Raspian Buster with Lazarus 2.0.0 and FPC 3.04
« Reply #5 on: September 04, 2019, 11:23:55 am »
I have buyed in summer in england the new Rpi4/4Go with a dowload of buster to make working pure PASCAL graphical programs on multi-plateforms and multi-OS. The purpose is to do mathematical works  ( matrix, curve 2D, 3D, 4D, ODE, PDE, pixel monte-carlo simulations ) without being ennoyed by OS. I had found my Graal by using FPC Compiler + the very interesting PTC graphical package to represent Mathematical behaviourism of Quaternion 4D space . My first problem was first downgrading Raspian OS because of the lack of graphical tools in then newest versions. PtcGraph and PtcCrt have not yet been implemented ... I wait for them ? But, on the Buster version for my Rpi4 the Fpc settings don't work yet, even for pure non-graphical calculations, because it don't find even the unit system. I wait for new OS debugging of Buster. Friendly. Yves .

Thaddy

  • Hero Member
  • *****
  • Posts: 8673
Re: Raspberry Pi, Raspian Buster with Lazarus 2.0.0 and FPC 3.04
« Reply #6 on: September 04, 2019, 12:00:37 pm »
Yves, can you be more specific, because I have not had *any* problems and are probably able to help.
Most people that want to use threading should learn to patch their jeans first: use a needle.

Brizeux

  • New Member
  • *
  • Posts: 11
Re: Raspberry Pi, Raspian Buster with Lazarus 2.0.0 and FPC 3.04
« Reply #7 on: September 04, 2019, 01:22:43 pm »
Thanks you very much, Thaddy. On the test "hello world", the buster FPC compiler of the Raspberry  hangs under compilation because it cann't find the unit "system" of Fpc. I have peep a glance on the units directory of Fpc under Buster and I found no reference to Ptc units like ptccrt.ppu and ptcgraph.ppu. My Rpi4/4Go is brand new from August and Buster version of Raspbian has been downloaded the same day and also all the fp packages with synaptic. My PASCAL programms run without any problem (Fpc+Ptc) under Core i7 / Wind 10 and Linux Ubuntu on ASUS or Dell Bi-Xeon Quad. I just wait for compability with others of the brand new Raspbian OS on new Rpi4 . I shall wait with philosophy. Yves .

Brizeux

  • New Member
  • *
  • Posts: 11
Re: Raspberry Pi, Raspian Buster with Lazarus 2.0.0 and FPC 3.04
« Reply #8 on: September 09, 2019, 06:15:32 pm »
I have found what happen : I agree Thaddy when you work on command line fpc blaise.pas works. O.K. . But when you use the same demo programm under fp-ide (fp command) the compiler abort : "(2,1) Fatal: Can't find unit system used by blaise" . I think that a link
in fp-ide is going wrong ?
I shall be glad also to have good Ptc news about "ptcgraph and ptccrt" for the last O.S. versions of Raspbian under Rpi3 and Rpi4...
It is a nightmare to downgrade versions in progress to do intelligent graphical software ! Yves .

Thaddy

  • Hero Member
  • *****
  • Posts: 8673
Re: Raspberry Pi, Raspian Buster with Lazarus 2.0.0 and FPC 3.04
« Reply #9 on: September 09, 2019, 07:25:28 pm »
Look if the /etc/fpc.cfg if all paths are correct. delete all other fpc.cfg's
Most people that want to use threading should learn to patch their jeans first: use a needle.

Brizeux

  • New Member
  • *
  • Posts: 11
Re: Raspberry Pi, Raspian Buster with Lazarus 2.0.0 and FPC 3.04
« Reply #10 on: September 10, 2019, 11:03:52 am »
Thanks you Taddy. I have try to understand somethiing to /etc/fpc.cfg but I understand nothing between
difference of fpc and the compiler of fp-ide. It is out of my mind of newby.
I shall stay on old Rpi3 with Fpc version 2.4.6 and old OS of Raspbian to use ptcgraph and ptccrt
for my scientific graphics. Friendly yours. Yves .

Thaddy

  • Hero Member
  • *****
  • Posts: 8673
Re: Raspberry Pi, Raspian Buster with Lazarus 2.0.0 and FPC 3.04
« Reply #11 on: September 10, 2019, 11:26:52 am »
Maybe your question was not clear enough, but FPC, FP and Lazarus work perfectly here. So ask more questions?
Most people that want to use threading should learn to patch their jeans first: use a needle.

Brizeux

  • New Member
  • *
  • Posts: 11
Re: Raspberry Pi, Raspian Buster with Lazarus 2.0.0 and FPC 3.04
« Reply #12 on: September 10, 2019, 03:17:37 pm »
O.K. Thaddy, I have found the (sic !!) solution. There is a mistake in fp-ide :
The solution to introduce system.ppu :
You open the IDE by the fp command.
The Tp7-like EDI screen is opened .
You click on "Options" .
You click on "Directories...'
and then like for Ptc stuff you add the Directory of the PASCAL unit system :
/usr/lib/arm-linux-gnueabihf/fpc/3.0.4/units/arm-linux/rtl/
and I have the greeting messages I was waiting for :
>>Fp ... a l'aise Blaise, dans Busher.<<
>>C'est Tout, les Mecs!!!! / That's All, Folks !!!!<<
Voili, Voilou, Voila !
Merci pour votre aide Thaddy. Friendly yours. Yves.   :D