Recent

Author Topic: Can't find unit LResources  (Read 7907 times)

kakarotv5

  • New Member
  • *
  • Posts: 42
Can't find unit LResources
« on: November 21, 2007, 04:51:46 pm »
I am trying to install the sockets components but I have got the error:

Code: [Select]
C:\lazarus\components\sockets\SocketClient.pas(27,11) Fatal: Can't find unit LResources used by SocketClient

How I solve this?

Thanks.
I have installed:
Lazarus-0.9.23-fpc-2.1.5-win32
Lazarus-0.9.23-fpc-2.1.5-cross-arm-wince-win32

I do not have a PDA but I use the Microsoft Windows Mobile 5.0 MSFP Emulator Images and Microsoft Windows Mobile 6 Emulator

Paul Ishenin

  • Sr. Member
  • ****
  • Posts: 274
RE: Can
« Reply #1 on: November 22, 2007, 12:41:24 am »
I think add LCL as dependency

kakarotv5

  • New Member
  • *
  • Posts: 42
RE: Can
« Reply #2 on: November 22, 2007, 03:12:09 am »
I solve the forward error.

In the Compiler Options menue I put in the field for Other Unit Files:

Code: [Select]
$(LazarusDir)\lcl\units\$(TargetCPU)-$(TargetOS)\

I put in the field for Include Files:

Code: [Select]
$(LazarusDir)\lcl\include\$(TargetCPU)-$(TargetOS)\

Thanks.
I have installed:
Lazarus-0.9.23-fpc-2.1.5-win32
Lazarus-0.9.23-fpc-2.1.5-cross-arm-wince-win32

I do not have a PDA but I use the Microsoft Windows Mobile 5.0 MSFP Emulator Images and Microsoft Windows Mobile 6 Emulator

Marc

  • Administrator
  • Hero Member
  • *
  • Posts: 2514
RE: Can
« Reply #3 on: November 22, 2007, 10:49:14 am »
Don't include the include files !
they are not needed, they are already compiled into a unit.
//--
{$I stdsig.inc}
//-I still can't read someones mind
//-Bugs reported here will be forgotten. Use the bug tracker

kakarotv5

  • New Member
  • *
  • Posts: 42
RE: Can
« Reply #4 on: November 22, 2007, 12:54:29 pm »
Quote from: "Marc"
Don't include the include files !
they are not needed, they are already compiled into a unit.


Ok, thanks.

I have installed the socket package (sockets-laz-package-0.2.0.tar.gz).

But I do not have the SocketServer component. Why?

Thanks.
I have installed:
Lazarus-0.9.23-fpc-2.1.5-win32
Lazarus-0.9.23-fpc-2.1.5-cross-arm-wince-win32

I do not have a PDA but I use the Microsoft Windows Mobile 5.0 MSFP Emulator Images and Microsoft Windows Mobile 6 Emulator

 

TinyPortal © 2005-2018