Recent

Author Topic: Could not directly access MySQL  (Read 3666 times)

andieyudha

  • Newbie
  • Posts: 3
Could not directly access MySQL
« on: January 22, 2008, 12:53:57 pm »
Hi, i'm a newbie on Lazarus... I've tried to made some simply application on it using MySQL as a Database. I have ;

1. TMySQLConnection
2. TSQLTransaction
3. TSQLQuery
4. TDataSource
5. TDBGrid

Everything is connected, and I've seen all rows on my TDBGrid, I tried to INSERTED, DELETED rows directly from TDBGrid and seems OK, but when i checked it from MySQL, that's nothing happened with my rows... There's no new rows..., Rows that i deleted is still there. I could figured it out. Somebody gimme your hand please... Thank's.

ssamayoa

  • Full Member
  • ***
  • Posts: 163
RE: Could not directly access MySQL
« Reply #1 on: January 22, 2008, 11:08:53 pm »
Did you commit?

andieyudha

  • Newbie
  • Posts: 3
Re: RE: Could not directly access MySQL
« Reply #2 on: January 23, 2008, 02:56:14 am »
Quote from: "ssamayoa"
Did you commit?


Thank's for your respons "ssamayoa". I don't understand
with your statement "did you commit". If you mean COMMIT
is the choice of TSQLQuery.Transaction.Action = 'caCommit'
my answer is yes. And i also tried with another option of
choices... caCommitRetaining, caNone,caRollback, and caRollbackRetaining.
The result is same... there's no change on my rows.

Shoud i send my project to you ???

Thank's GBU

 

TinyPortal © 2005-2018