Recent

Author Topic: LazReport can not open my old reports  (Read 3674 times)

nelson777

  • Jr. Member
  • **
  • Posts: 68
    • http://www.aocontrario.com
LazReport can not open my old reports
« on: November 08, 2007, 02:55:56 am »
Recently I updated both Lazarus and LazReport to the latest snapshot/version. Unfortunately I don´t´t remember what was the exact snapshot, but after that I just can´t open my reports anymore.
I read somewhere that Lazarus recently included lazreport in the snapshot. Some questions:

1-What is the latest LazReport component, the one present in Lazarus snapshot (I have the latest: 2007-11-07) or LazReport-0.9.5-20070904.tar.gz from LazReport´s page ?

2-I have the reports in the LFM, not in an external file. Is there some converter that can extract from the lfm to a lazreport loadable file ?

3-The error I got is 'Error Reading from lrMod.RepotForm: Paper "" not supported !', both when I try to open the Design Report. and in run-time; Somebody knows why is this ? Is there any workaround ? Tryed to change printer, nothing happend.

4-I tried to unnistall Lazarus and install Lazarus 0.9.22 version and LazReport 0.94 version. Still doesn´t work.

5-I can´t edit the form in the LFM because it´s bunch of hex codes. WHat are my options ?

Any help is appreciated.  Thnx in advance.

- Nelson
Blog: www.aocontrario.com

nelson777

  • Jr. Member
  • **
  • Posts: 68
    • http://www.aocontrario.com
RE: LazReport can not open my old reports
« Reply #1 on: November 09, 2007, 05:15:09 pm »
I was wrong in questions 2 and 5 above. I got the .lrf files, but they just won´t open in the 7/11 buld. Is there a change list of Lazarus builds somewhere ?

nelson777

  • Jr. Member
  • **
  • Posts: 68
    • http://www.aocontrario.com
RE: LazReport can not open my old reports
« Reply #2 on: November 10, 2007, 12:43:15 am »
Ok.. I found what the problem was, just in case someone need this also. The .lrf file had as default printer, a network printer, I just change directly in file and all was fixed up. The printer is a "LEXMARK T520 PS". Maybe there is some incompatibility between this driver and LazReport.