Recent

Author Topic: Error on start of IDE  (Read 405 times)

RedOctober

  • Sr. Member
  • ****
  • Posts: 253
Error on start of IDE
« on: May 16, 2019, 04:44:23 am »
I was able to get QuickPDF 10.13 ActiveX library installed into Lazarus 1.8.4 FPC 3.0.4.
It's working well, however, when ever I opened an existing previously created form in the IDE to work on it, even a form that doesn't have anything to do with the QuickPDF ActiveX library, I would get an error message saying that a file was missing and the file name was the name of the ActiveX library but with a "reg" tacked on the end. The dialog gave me the option of "Install this package", so I clicked it and it successfully installed and rebuilt the IDE.  However, that created another problem.  Now, when ever I close the IDE and reopen, I get the following error message.  How do I fix this?


[Window Title]
Package registration error

[Content]
Package: "DebenuPDFLibraryAX1013_10_13_TLBP 0.1"
lpk file: "D:\Projects\Lazarus\Rubi\rubi_core\src\DebenuPDFLibraryAX1013_10_13_TLBP.lpk"
Unit Name: "DebenuPDFLibraryAX1013_10_13_TLBPreg"
File Name: "D:\Projects\Lazarus\Rubi\rubi_core\src\DebenuPDFLibraryAX1013_10_13_TLBPreg.pas"

Component Class "TAxcPDFLibrary" already defined

[Ignore] [Ignore all] [Abort]


Thanks in advance for any help you can provide.



RAW

  • Hero Member
  • *****
  • Posts: 781
Re: Error on start of IDE
« Reply #1 on: May 16, 2019, 06:41:02 am »
On Windows you can delete the lazarus.exe and rename the old or backup exe that is automatically created by Lazarus. If you don't need any DesignTime functionality, then tell Lazarus the path to the library and use it only runtime ...
Windows 7 Pro (x64 Sp1) And Windows XP Pro (x86 Sp3) - LAZARUS 2.0.4 FPC 3.0.4 - TRUNK 2.1.0 FPC 3.3.1

RedOctober

  • Sr. Member
  • ****
  • Posts: 253
Re: Error on start of IDE
« Reply #2 on: May 16, 2019, 03:00:03 pm »
I can certainly delete the lazarus.exe files, but how do I "tell Lazarus the path to the library and use it only runtime .." ?

RedOctober

  • Sr. Member
  • ****
  • Posts: 253
Re: Error on start of IDE
« Reply #3 on: May 16, 2019, 03:03:28 pm »
Also, once I delete the lazarus.exe and the backup, how do I use Lazarus?

Handoko

  • Hero Member
  • *****
  • Posts: 3100
  • My goal: build my own game engine using Lazarus
Re: Error on start of IDE
« Reply #4 on: May 16, 2019, 03:05:30 pm »
how do I "tell Lazarus the path to the library ... ?

Try this:
Lazarus main menu > Project > Project Options > Compiler Options > Paths

RedOctober

  • Sr. Member
  • ****
  • Posts: 253
Re: Error on start of IDE
« Reply #5 on: May 16, 2019, 05:01:21 pm »
Thanks for the help guys.  I was able to fix the problem by:

- Uninstall the ActiveX package, rebuild and restart Lazarus
- Add the path to the TLB package to "Paths"
- Probably not necessary because of the previous steop, but I copied
    DebenuPDFLibrary64AX1013_10_13_TLB.* to the project source folder

- Install ONLY the 64 bit QuickPDF ActiveX package

I can now start Lazarus and open my forms without getting the missing file warning.

Note that there is a 32b DLL and I think that was what was causing the problem. You should only install only the 64bit DLL and TLB etc.