Recent

Author Topic: Best recommended web browsing component  (Read 227 times)

Saylo_49

  • New member
  • *
  • Posts: 32
Best recommended web browsing component
« on: May 13, 2019, 12:45:11 pm »
Hello

I am working on a project that contain web browsing feature (open a web page inside it and do a web search)

So what is the best and clean (and cross-platform) component to use
  fpCEF (https://github.com/dliw/fpCEF3 - last commit in May 24, 2018)
  CEF4Delphi (https://github.com/salvadordf/CEF4Delphi - tested on Lazarus 2.0.2 and last commit May 11, 2019)
  LazWebKit
  or is there an other unknown component

-------- And almost I forget
I need a component with WindowsXP compatibility available

Thnx forward
« Last Edit: May 13, 2019, 01:07:57 pm by Saylo_49 »
Lazarus 2.0.2 - FPC 3.0.4 - Win32

avra

  • Hero Member
  • *****
  • Posts: 1504
    • Additional info
Re: Best recommended web browsing component
« Reply #1 on: May 13, 2019, 01:24:01 pm »
CEF4Delphi (https://github.com/salvadordf/CEF4Delphi - tested on Lazarus 2.0.2 and last commit May 11, 2019)
It was the only one that worked for me without any installation issues. It doesn't mean that it is better then the others - I am just saying that it worked for me. My use case was pretty basic so I can not say much about advanced usage either. It is a shame that there are only a few Lazarus examples. However, more then half of Delphi examples can be converted. I did that and one of these days I will donate those converted projects back to the author.

I need a component with WindowsXP compatibility available
You will need older Chromium engine compatible with Windows XP: https://github.com/salvadordf/OldCEF4Delphi. Unfortunately it doesn't have Lazarus package. You will have to adapt it.
« Last Edit: May 13, 2019, 01:35:01 pm by avra »
ct2laz - Conversion between Lazarus and CodeTyphon
bithelpers - Bit manipulation for standard types
pasettimino - Siemens S7 PLC lib

salvadordf

  • New member
  • *
  • Posts: 15
    • BriskBard
Re: Best recommended web browsing component
« Reply #2 on: May 14, 2019, 04:34:57 pm »
If you need WindowsXP then you need to use a CEF wrapper that includes CEF3.2623 or older.
If you need to a cross-platform component then you can only use fpCEF because CEF4Delphi only supports Windows at this moment.

I've never used LazWebKit and I don't know if it supports all you need.
Maintainer of the CEF4Delphi project.