Recent

Author Topic: idemake.cfg not found if accute in file path  (Read 185 times)

regent@air-g.net

  • Newbie
  • Posts: 1
idemake.cfg not found if accute in file path
« on: May 09, 2019, 02:39:07 am »
With lazarus 2.0.0 RC3 and below all was working fine whwn rebuilding IDE after adding package

with 2.0.0 finale and 2.0.2 install goes well and IDE opens, but if i add a package and try to rebuild IDE i get

C:\Users\RÙgent\AppData\Local\lazarus\idemake.cfg is missing

it should be:
C:\Users\Régent\AppData\Local\lazarus\idemake.cfg

If i un-install all and re-install 2.0.0 RC3 all is working again when i rebuild
« Last Edit: May 09, 2019, 02:40:46 am by regent@air-g.net »

khoward

  • New member
  • *
  • Posts: 28
Re: idemake.cfg not found if accute in file path
« Reply #1 on: May 15, 2019, 03:49:23 pm »
Hi Regent,
I can confirm similar behavior, except, with mine, it removes all of the slashes from the directory path! :(
It worked in 2.0, but 2.0.2 does not work. 
I get: 
Fatal: Unable to open file C:UserskhowardAppDataLocallazarusidemake.cfg -dx86_64
If you should find a solution, I'm most interested.I'll let you know if I learn anything as well.
Thanks!
Keith

af0815

  • Sr. Member
  • ****
  • Posts: 269
Re: idemake.cfg not found if accute in file path
« Reply #2 on: May 16, 2019, 07:33:53 am »
it should be:
C:\Users\Régent\AppData\Local\lazarus\idemake.cfg
It looks you have a special character in your path, this (can) make troubles.
regards
Andreas

khoward

  • New member
  • *
  • Posts: 28
Re: idemake.cfg not found if accute in file path
« Reply #3 on: May 16, 2019, 04:48:07 pm »
Hi Andreas,
As Regent and myself pointed out, though, it used to work in an earlier version.I suppose we are looking for confirmation and, perhaps if enough other people experience this, file a bug report.My situation is really weird though.....no directory slashes for some reason.I installed Laz 2.0.2 on a spare laptop and I can rebuild the IDE....no problem.I don't know what the difference could be.
Thanks.
Keith